Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive an "Access Violation (0xC0000005 exception)" error in Internet Explorer 6.0


View products that this article applies to.

Symptoms

Microsoft Internet Explorer 6.0 stops responding when you try to open an HTML document or a Web page. Additionally, you receive the following error message:
Access Violation (0xC0000005 exception)

↑ Back to the top


Cause

This problem may occur when you use Internet Explorer 6.0 to open an HTML document or a Web page that contains SPAN tags. If a SPAN tag is not closed correctly by using the </SPAN> tag, an access violation may occur.

The <SPAN> tag is an inline element that renders text by using a style sheet. The tag is typically used to change the style of an element or of a block of text.

<SPAN> tags are also used to group inline elements in an HTML document. For example, the following HTML document may cause an access violation because the </SPAN> tag is missing.
<html>
  <body>
      <style type="text/css">
        #three
          {
          position: absolute;
          }
        #one #two
          {
          position: absolute;
          }
      </style>

      <div id="one">
        In 'one'
        <SPAN id="two">
          In 'two'

-> The </SPAN> tag is missing 

      </div>

      <div id="three">
        In 'three'
      </div>
  </body>
</html>

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Internet Explorer 6.0 SP1 for Windows Server 2003 x86

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   27-Oct-2004  00:40  6.0.3790.227    2,925,056  Mshtml.dll       


Internet Explorer 6.0 SP1 for Windows Server 2003 IA-64

   Date         Time   Version            Size    File name
   -------------------------------------------------------------------
   27-Oct-2004  01:43  6.0.3790.227    8,230,912  Mshtml.dll     IA-64
   27-Oct-2004  01:40  6.0.3790.227    2,925,056  Wmshtml.dll    x86


Internet Explorer 6.0 SP1

   Date         Time    Version            Size      File name
   --------------------------------------------------------------
   17-Jun-2004  00:01   6.0.2800.1449    2,692,096   Mshtml.dll 

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbhotfixserver, kbqfe, kbqfe, kbie600sp2fix, kbfix, kbbug, kbie600presp2fix, kbprb, kbautohotfix, KB832823

↑ Back to the top

Article Info
Article ID : 832823
Revision : 11
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 467