Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

BUG: The Host Integration Server Management Console snap-in does not start


View products that this article applies to.

Symptoms

When you open the Microsoft Management Console (MMC) SNA Manager snap-in, the snap-in stops responding (hangs) for about 60 seconds, and then you receive the following error message:

Communication with the servers has been lost. SNA Manager must be restarted.
In addition, an Event 5149 that is similar to the following is logged in the application event log:

Event ID: 5149 Event Source: SNA Manage Agent Description: Manage base error - error in accessing the domain table. The local domain name is not valid

↑ Back to the top


Cause

A handle against a certain semaphore that indicates that the MngClient process is running is not closed in all situations. Therefore, the Management Console assumes that this process is running when it is not running.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size     File name
   ----------------------------------------------------
   10-Nov-2003  21:56  5.0.0.952  114,960  Mngbase.dll
   10-Nov-2003  21:56  5.0.0.952  102,672  Mngagent.exe
   10-Nov-2003  21:56  5.0.0.952  102,672  Mngcli.exe

				

Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

↑ Back to the top


More information

When the Host Integration Server MMC snap-in is started, the MngClient initializes and creates the MNG_PROXY_TERM_SEM_NAME semaphore. The MNG_PROXY_TERM_SEM_NAME semaphore remains open until MngClient closes.

When the MMC console or the Windows Management Instrumentation (WMI) provider starts, it first tries to open this semaphore. If the semaphore with this name exists in the system, SNA Manager assumes that the MngClient is running. Otherwise, the SNA Manager will try to start a new instance of the MngClient. Therefore, the MNG_PROXY_TERM_SEM_NAME semaphore indicates the existence of the MngClient.

In some circumstances, the MngClient does not call the CloseHandle function against this semaphore. This behavior is okay most of the time because the system cleans up all handles of a process after the process is unloaded. However, if the handle is not closed, a timing window increases because the operating system takes some time to unload the process and to perform the cleanup. This increased time window causes the problem that is described in the "Symptoms" section.

↑ Back to the top


Keywords: KB831893, kbhotfixserver, kbqfe, kbfix, kbbug

↑ Back to the top

Article Info
Article ID : 831893
Revision : 3
Created on : 10/26/2005
Published on : 10/26/2005
Exists online : False
Views : 390