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Messages to local distribution lists are queued for remote delivery after you remove an Exchange 5.5 computer


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Symptoms

After you remove one of the Exchange 5.5 computers from your organization by using the Exchange Administrator tool, messages are no longer delivered successfully to some distribution lists. All messages to certain distribution lists whose members are from the same Exchange site or administrative group are not delivered. Instead, the messages back up in the remote delivery queue. You can successfully send messages to the individual members of the distribution list. This problem occurs in organizations where the following conditions exist:
  • You have a mixed Microsoft Exchange 2000 Server and Microsoft Exchange Server 5.5 organization.
  • The Internet Mail Service is installed on the Exchange 5.5 computer.
  • You replicate all objects to the Microsoft Active Directory directory service by using Active Directory Connector (ADC).
  • You rehome all public folders and mailboxes to an Exchange 2000 computer.

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Cause

This behavior may occur if the Exchange 5.5 computer that you removed was the expansion server for the distribution list that you tried to send the messages to. In this scenario, the distribution list cannot be expanded because the Exchange computer no longer exists in the organization.

Note In the Exchange Administrator tool, the distribution list may have the Any option selected for the expansion server.

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Resolution

To resolve this issue, use the ADSI Edit snap-in to specify a new expansion server for the distribution list. To do this, follow these steps.

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.
  1. Click Start, click Run, type adsiedit.msc in the Open box, and then click OK.

    Note ADSI Edit is included with the Microsoft Windows 2000 Support Tools. For additional information about how to install the Windows 2000 Support Tools, click the following article number to view the article in the Microsoft Knowledge Base:
    301423� HOW TO: Install the Windows 2000 Support Tools to a Windows 2000 Server-Based Computer
  2. Expand Domain NC [servername.yourdomain.com], and then expand DC=yourdomain,DC=com.

    In this step, servername is the name of a domain controller, and yourdomain.com is the name of the domain.
  3. Expand the container where the distribution list is located.

    For example, expand CN=MigratedObjects.
  4. Right-click the distribution list that you want to specify a new expansion server for, and then click Properties.
  5. In the Select which properties to view list, click Both.
  6. In the Select a property to view list, click msExchExpansionServerName.

    Note The Value(s) box contains the name of the Exchange 5.5 computer that you removed.
  7. Do one of the following:
    • To specify a particular expansion server, type the name of an Exchange 2000 computer in the Edit Attribute box, click Set, and then click OK.
    • To specify any computer in the administrative group as an expansion server, click Clear, remove the contents of the Edit Attribute box, click Apply, and then click OK.
  8. Quit ADSI Edit, and then wait for these changes to replicate throughout your organization.
After the changes replicate throughout the organization, you can successfully deliver messages to the distribution list.

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Keywords: KB831603, kbprb

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Article Info
Article ID : 831603
Revision : 2
Created on : 10/27/2006
Published on : 10/27/2006
Exists online : False
Views : 296