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You receive error code 80090006 when the Exchange System Attendant service tries to start


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Symptoms

You cannot start the Microsoft Exchange services on your Microsoft Exchange 2000 Server computer. When the Microsoft Exchange System Attendant service tries to start, the following events are logged in the application event log:

Event Type: Error
Event Source: MSExchangeMU
Event ID: 1009
Description:
Failed to access the metabase, error code is 80090006 (Invalid Signature).

Event Type: Error
Event Source: MSExchangeMU
Event ID: 1002
Description:
Metabase Update agent failed to start. Error code is 80090006 (Invalid Signature).

Event Type: Error
Event Source: MSExchangeSA
Event ID: 9004
Description:
The Metabase Update service failed to start, error '80090006'.

Event Type: Error
Event Source: MSExchangeSA
Event ID: 1005
Description:
Unexpected error Invalid Signature. ID no: 80090006 Microsoft Exchange System Attendant occurred.



The error description for the 80090006 error code that appears in the event log messages is "Invalid Signature." When the 80090006 error code appears, and you try to open the Internet Services Manager snap-in, you may receive the following error message:
Invalid signature.
The error may also appear in the event log as the 8007000d error code. The error description for the 8007000d error code is "Data Invalid." When the 8007000d error code appears, and you try to open the Internet Services Manager snap-in, you may receive the following error message:
The data is invalid.
The error code may also appear in the event log as the 80004002 error code. The error description for the 80004002 error code is "No Such Interface." When the 80004002 error code appears, and you try to open the Internet Services Manager snap-in, you may receive the following error message:
No such interface.
Additionally, when you try to start the World Wide Web Publishing Service, you may receive one of the following error messages:
Could not start the WWW Publishing Service. Error 1008. An attempt was made to reference a token that does not exist.
Could not start the WWW Publishing Service. No error was returned. This could be an internal Windows NT error or an internal service error.

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Cause

This issue may occur if there is corruption of the Microsoft Internet Information Services (IIS) metabase on the Exchange 2000 Server computer. Corruption of the IIS metabase may occur for a variety of reasons, including the following:
  • The SystemRoot\System32\Inetsrv folder was scanned by an antivirus agent.
  • The Exchange 2000 Server computer is affected by hardware issues.
  • The Exchange 2000 Server computer was affected by a power outage.

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Resolution

To resolve this issue, restore the Metabase.bin file from backup or reinstall IIS and Exchange 2000.

Method 1: Restore the Metabase.bin file from backup

To restore the Metabase.bin file from backup, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
  2. Click the Exchange 2000 computer name, and then click Backup/Restore Configuration on the Action menu.
  3. In the Configuration Backup/Restore dialog box, click a backup file if a backup file exists, and then click Restore.
  4. When you are prompted to restore your configuration settings, click Yes
If the name of your computer is not listed in Internet Services Manager, or if you receive an error when you try to start Internet Services Manager, follow these steps:
  1. Type net stop iisadmin /y at a command prompt to stop all IIS services.
  2. Rename the corrupted Metabase.bin file to Metabase.old.

    The Metabase.bin file is located in the SystemRoot\System32\Inetsrv folder.
  3. If the backup metabase file exists, copy the backup metabase file to the SystemRoot\System32\Inetsrv folder.

    The backup metabase file is named FileName.mdBackupNumber. The backup metabase file is located in the SystemRoot\System32\Inetsrv\Metaback folder.
  4. Rename the backup metabase file to Metabase.bin.
  5. Restart the computer.
For additional information about how to restore the Metabase.bin file, click the following article number to view the article in the Microsoft Knowledge Base:
234429 How to manually restore the metabase when no proper backup exists or when the MMC does not start

Method 2: Reinstall IIS and Exchange 2000

Microsoft recommends that you back up the Mdbdata folder on your Exchange 2000 server before you reinstall IIS and Exchange 2000. The Mdbdata folder is typically located in the SystemRoot\Program Files\Exchsrvr folder.

To reinstall IIS and Exchange 2000, follow these steps:
  1. Rename the Metabase.bin file to Metabase.old.

    The Metabase.bin file is located in the SystemRoot:\Winnt\System32\Inetsrv folder.
  2. Use Add/Remove Programs in Control Panel to remove IIS, and then reinstall IIS.

    For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
    325889 How to remove and reinstall IIS 5.0 and 5.1
  3. Reapply Microsoft Windows 2000 service packs and updates.
  4. Use Add/Remove Programs in Control Panel to reinstall Exchange 2000:
    1. In Control Panel, click Add/Remove Programs, click Microsoft Exchange 2000, and then click Change/Remove.
    2. In Microsoft Exchange 2000 Installation Wizard, click Next.
    3. In the Action column, click Reinstall for each component that is installed, click Next, and then follow the instructions that appear on the screen to complete the steps in the wizard.
  5. Reapply Exchange 2000 service packs and updates.
  6. Start the Exchange services.
Note You do not have to restore the Exchange 2000 databases.

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More information

Microsoft recommends that you back up the IIS metabase regularly, either as part of the System State backup or as a separate backup. For additional information about how to back up the metabase, click the following article number to view the article in the Microsoft Knowledge Base:
302573 How to back up and restore IIS

For additional information about how to reinstall IIS and Exchange 2000, click the following article number to view the article in the Microsoft Knowledge Base:
320202 How to remove and reinstall IIS and Exchange

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Keywords: KB831393, kbprb

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Article Info
Article ID : 831393
Revision : 2
Created on : 10/27/2006
Published on : 10/27/2006
Exists online : False
Views : 298