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An invokable transaction program (TP) is not available after you restart Host Integration Server 2000


View products that this article applies to.

Symptoms

After you restart the Microsoft Host Integration Server 2000 server, the server may stop forwarding Function Management Header-5 (FMH-5) Attach messages to a Host Integration Server 2000 client computer that is running a certain kind of invokable transaction program (TP). This TP is either an Advanced Program-to-Program Communications (APPC) TP or a Common Programming Interface for Communications (CPI-C) TP.

This problem may also occur if you restart the SnaBase service on the Host Integration Server 2000 server.

Additionally, when the FMH-5 Attach message cannot be routed to the invokable TP, the following event is logged in the application event log on the Host Integration Server 2000 server:
Event ID: 60
Source: SNA Server
Description: Failed to invoke APPC TP <TP Name>, sense data = 084C0000
Note You experience these symptoms only in a Host Integration Server 2000 subdomain that contains a single Host Integration Server 2000 server.

The rest of this article refers to the Host Integration Server 2000 server as "the server" and refers to the Host Integration Server 2000 client computer as "the client".

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Cause

This problem occurs because the server cannot route an incoming FMH-5 Attach message to an invokable TP if the invokable TP is not registered in the service table of the server. The following describes how this problem occurs:
  • When you restart the server, the client that is running the invokable TP detects that its sponsor connection to the server has been disconnected.
  • The client tries to reconnect to the server one time.
  • If this connection attempt is unsuccessful, the client does not reconnect to the server.
  • The result is that the invokable TP is not re-registered in the service table of the server.

    The server cannot route an incoming FMH-5 Attach message to an invokable TP if the invokable TP is not registered in the service table of the server.

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Resolution

Note You must apply the update for this problem to both the Host Integration Server 2000 server and the Host Integration Server 2000 client.

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   ------------------------------------------------------
   10-Dec-2003  01:57  5.0.0.957   286,992  Snabase.exe
Note Because of file dependencies, the most recent fix that contains the previous files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

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More information

After the update

After you apply the update to a client that is running an invokable TP, the client tries repeatedly to reopen its sponsor connection to the server that was restarted. Although the default time between each connection attempt is 15 seconds, you can change the retry delay by adding the SponsorRetryDelay registry entry. Follow the steps that are described in the following article:
180467� SNA Client does not retry other sponsors after error response

Multiple servers in the subdomain

This problem does not occur if multiple servers exist in the Host Integration Server 2000 subdomain because the client can open a sponsor connection to one of the other servers after the client loses its original sponsor connection. When the client opens a sponsor connection to one of the other servers, the invokable TP is registered in the service table on that other server. After the invokable TP is registered in one of the service tables on the other server, this registration information is communicated to the rest of the servers in the Host Integration Server 2000 subdomain, including the server that you restarted.

If you apply this hotfix to multiple Host Integration Server 2000-based servers in a subdomain, the problem that is described in the following Microsoft Knowledge Base article will occur:
875546� FIX: You receive an "Event 60" in the application event log after you restart a server that is running Host Integration Server 2000 Service Pack 1 in a multiple-server Host Integration Server subdomain
For additional information about how the sponsor connection works, click the following article number to view the article in the Microsoft Knowledge Base:
317805� Sponsor connection changes in Host Integration Server 2000

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Keywords: KB829980, kbhotfixserver, kbqfe, kbfix, kbbug

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Article Info
Article ID : 829980
Revision : 4
Created on : 10/26/2005
Published on : 10/26/2005
Exists online : False
Views : 347