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Non-Delivery Reports Appear to Be from the Incorrect Domain


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Symptoms

When you send an e-mail message to a recipient who does not exist in a Microsoft Exchange 2000 Server or Exchange Server 2003 organization, you receive a non-delivery report (NDR). However, the non-delivery report may appear to originate from a domain that is different from the domain that you sent the e-mail message to.

For example, if you (sender@adatum.com) send a message to user@contoso.com, you receive a non-delivery report that is similar to the following from postmaster@contoso.local:
From:  postmaster@contoso.local
Sent:  03 November 2003 11:08
To:    sender@adatum.com
Subject: Delivery Status Notification (Failure)

This is an automatically generated Delivery Status Notification.

Delivery to the following recipients failed.

 	user@contoso.com
As a result, it might not be clear why you received a non-delivery report from a domain that appears to be the incorrect domain. Additionally, when you reply to this non-delivery report, your reply message may not be delivered successfully.

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Cause

This issue occurs when the following configuration exists in the Exchange Server organization:
  • A default recipient policy is defined to stamp all user objects with a primary Simple Mail Transfer Protocol (SMTP) address.
  • A higher-priority recipient policy is defined to stamp all user objects with a different primary SMTP address.

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Workaround

To work around this issue, use one of the following methods:

Method 1: Change the Default Recipient Policy

Change the default recipient policy to the domain that you want delivery status notifications to be sent from. For additional information about recipient policies, click the following article numbers to view the articles in the Microsoft Knowledge Base:
249299 HOW TO: Configure Recipient Policies in Exchange
319201 HOW TO: Use Recipient Policies to Control E-mail Addresses in Exchange 2000
If you change the default recipient policy to the domain that you want delivery status notifications to be sent from, you must restart the Exchange computers in the organization.

Method 2: Create a Transport Event Sink

Create a transport event sink to rewrite the delivery status notification message to use the domain that you want the message to be sent from. For additional information about how to write a transport event sink, visit the following Microsoft Web sites:
Writing Managed Sinks for SMTP and Transport Events:
http://msdn2.microsoft.com/en-us/library/ms998610.aspx
Introduction to the Event Sink Wizard:
http://msdn2.microsoft.com/en-us/library/ms987891.aspx

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More information

When this issue occurs, if the intended recipient does not exist in the Exchange Server organization, the non-delivery report is generated and stamped with the domain that is specified by the default recipient policy.

For example, if the primary SMTP address that is defined in the default recipient policy is @contoso.local and a higher-priority recipient policy stamps objects with the SMTP address of @contoso.com, you receive a non-delivery report from postmaster@contoso.local when you send a message to a user who does not exist in the organization.

For additional information about delivery status notifications, click the following article number to view the article in the Microsoft Knowledge Base:
284204 Delivery Status Notifications in Exchange 2000 Server

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Keywords: KB829108, kbprb

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Article Info
Article ID : 829108
Revision : 7
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 288