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COMTI Pooled Components Do Not Always Activate on Startup


View products that this article applies to.

Symptoms

A client program may be unable to create an instance of a COM Transaction Integrator (COMTI) component if the COMTI component is configured to Enable Object Pooling in Component Services.

This intermittent problem is more likely to occur if many COMTI type libraries are installed in the same Component Services application package.

This problem occurs only when the application package first starts.

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Cause

This problem occurs because of a timing issue that can cause a condition of deadlock to occur when the COMTI runtime is initializing. This deadlock occurs only when Object Pooling is enabled.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -------------------------------------------------------------------
   10-Sep-2003  18:55  5.0.0.938          37,136  Capture.dll      
   10-Sep-2003  18:55  5.0.0.938         323,856  Cedrmsgs.dll     
   10-Sep-2003  18:55  5.0.0.938          33,040  Comticontext.dll  
   10-Sep-2003  18:55  5.0.0.938         147,728  Convert.dll      
   10-Sep-2003  18:55  5.0.0.938          74,000  Convertprim.dll  
   10-Sep-2003  18:55  5.0.0.938          33,040  Dpl1.dll         
   10-Sep-2003  18:56  5.0.0.938         823,568  Dtcob390.dll     
   10-Sep-2003  18:55  5.0.0.938          37,136  Playback.dll     
   10-Sep-2003  18:55  5.0.0.938          78,096  Readlib.dll      
   10-Sep-2003  18:55  5.0.0.938         123,152  Tadtlb.dll       
   10-Sep-2003  18:55  5.0.0.938         114,960  Tagen.dll        
   10-Sep-2003  18:55  5.0.0.938          82,192  Tranlu62.dll     
   10-Sep-2003  18:55  5.0.0.938         110,864  Trantcp.dll      
   10-Sep-2003  18:55  5.0.0.938          49,424  Turnaround.dll   
   10-Sep-2003  18:56  5.0.0.870         950,272  Componentbuilder.exe  
   29-Mar-2003  01:15                    838,423  Comticb.chm
   29-Mar-2003  01:15                    812,988  Resnapin.chm
Note Because of file dependencies, the most recent fix that contains the preceding files may also contain additional files.

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Workaround

If the deadlock occurs, use the Component Services Manager to shut down the Component Services application package, and then try to start the application again.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

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Keywords: KB828360, kbhotfixserver, kbprb, kbhis2000fix, kbqfe

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Article Info
Article ID : 828360
Revision : 3
Created on : 10/26/2005
Published on : 10/26/2005
Exists online : False
Views : 392