Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Double-byte character set characters are not displayed correctly in an Exchange Server 5.5 mailbox when they are transferred by the Exchange 2000 MTA


View products that this article applies to.

Symptoms

When a user in a Microsoft Exchange 2000 Server organization sends an e-mail message that includes double-byte character set (DBCS) characters in the Subject line or in the body of the message, the DBCS characters are not displayed correctly for a Microsoft Exchange 5.5 user if both of the following conditions are true:
  • The e-mail message is transferred by the Exchange 2000 Message Transfer Agent (MTA) to a Microsoft Exchange Server 5.5 mailbox.
  • The character set has not been specified for the message. For example, the message is sent through a third-party mail program or by a script that does not specify the character set.

↑ Back to the top


Cause

This problem occurs because the character set is configured to the default ISO-8859-1 setting when a message is transferred by the Exchange 2000 MTA to an Exchange Server 5.5 mailbox.

↑ Back to the top


Resolution

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   15-Oct-2003  23:31  6.0.6521.0      3,915,776  Cdoex.dll        
   15-Oct-2003  23:25  6.0.6521.0        851,968  Davex.dll        
   15-Oct-2003  23:25  6.0.6521.0         53,248  Davexpc.dll      
   15-Oct-2003  23:22  6.0.6521.0        131,072  Drviis.dll       
   15-Oct-2003  23:22  6.0.6521.0        577,536  Dsaccess.dll     
   15-Oct-2003  22:33  6.0.6521.0        184,320  Dscmsg.dll       
   15-Oct-2003  22:33  6.0.6521.0        962,560  Emsmdb32.dll     
   15-Oct-2003  23:25  6.0.6521.0      2,179,072  Ese.dll          
   15-Oct-2003  23:25  6.0.6521.0         40,960  Eseperf.dll      
   09-Sep-2003  02:18                      6,991  Eseperf.hxx
   15-Oct-2003  23:25                    391,634  Eseperf.ini
   15-Oct-2003  23:31  6.0.6521.0      3,575,808  Excdo.dll        
   15-Oct-2003  23:22  6.0.6521.0        262,144  Exmime.dll       
   15-Oct-2003  23:25  6.0.6521.0        143,360  Exodbesh.dll     
   15-Oct-2003  23:25  6.0.6521.0         57,344  Exodbpc.dll      
   15-Oct-2003  23:25  6.0.6521.0        200,704  Exodbprx.dll     
   15-Oct-2003  23:25  6.0.6521.0      2,179,072  Exoledb.dll      
   15-Oct-2003  23:20  6.0.6521.0         81,920  Exosal.dll       
   15-Oct-2003  23:25  6.0.6521.0        307,200  Exprox.dll       
   15-Oct-2003  22:36  6.0.6521.0        143,360  Exschema.exe     
   15-Oct-2003  23:25  6.0.6521.0        315,392  Exsmtp.dll       
   15-Oct-2003  22:38  6.0.6521.0        675,840  Exwform.dll      
   15-Oct-2003  23:23  6.0.6521.0         40,960  Jcb.dll          
   15-Oct-2003  22:18  6.0.6521.0        745,472  Mapi32.dll       
   15-Oct-2003  22:13  6.0.6521.0         49,152  Mdbevent.dll     
   15-Oct-2003  22:30  6.0.6521.0      2,285,568  Mdbmsg.dll       
   15-Oct-2003  22:15  6.0.6521.0         32,768  Mdbrole.dll      
   15-Oct-2003  23:23  6.0.6521.0         24,576  Mdbtask.dll      
   15-Oct-2003  23:19  6.0.6521.0         94,208  Peexch50.dll     
   15-Oct-2003  23:20  6.0.6521.0        397,312  Phatcat.dll      
   15-Oct-2003  23:23  6.0.6521.0        532,480  Reapi.dll        
   15-Oct-2003  23:25  6.0.6521.0        311,296  Resvc.dll        
   15-Oct-2003  23:21  6.0.6521.0      4,657,152  Store.exe        
   15-Oct-2003  22:38  6.0.6521.0      3,735,552  Wmtemplates.dll  
   
Note Because of file dependencies, this update requires Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378� How to obtain the latest Exchange 2000 Server service pack

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB827880, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbtransport, kbexchange2000presp4machbarfix, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 827880
Revision : 6
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 270