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"Installation source has been corrupted" error message when you install Office 2003


View products that this article applies to.

Symptoms

When you install Microsoft Office 2003, you may receive the following error message:
Microsoft Office setup cannot continue because the installation source has been corrupted.

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Cause

This problem may be caused by an incorrect version of the Microsoft XML Parser (MSXML) program installed on your computer. This is typically installed with Microsoft Internet Explorer 6 and comes preinstalled on Microsoft Windows XP-based computers. By repairing or reinstalling Internet Explorer 6, you can repair MSXML.

Note By default, Internet Explorer 6 is preinstalled in all versions of Windows XP. To provide computer manufacturers more flexibility in configuring desktop versions of Windows XP, Microsoft has made it possible for OEMs, administrators, and users to remove user access to Internet Explorer while leaving the Internet Explorer code intact and fully functional to ensure the functionality of programs and operating system functions that rely on it. For example, Windows XP supports an IEAccess=off switch in the Unattend.txt file, and Internet Explorer has been added to the Add/Remove Windows Components section of the Add/Remove Programs tool in Control Panel.

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Resolution

To resolve this problem, use the following methods in the order in which they are presented.

Microsoft XML Parser 3.0 Service Pack 4

Install the latest version of Microsoft XML Parser (MSXML) from the Microsoft Download Center.

Release Date: 8-26-2003

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file. To download the files, visit the following Microsoft Web site:

Reregister the Msxml3.dll file

Reregister the file Msxml3.dll. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type the following : Regsvr32.exe MSXML3.DLL, and then click OK.
If the Msxml3.dll file is successfully registered, you receive a message that is similar to the following:
DllRegisterServer in C:\WINDOWS\system32\MSXML3.DLL succeeded.

Repair Internet Explorer

To repair your installation of Internet Explorer, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Double-click Microsoft Internet Explorer version.
  4. Click Repair the current installation of Internet Explorer, and then click OK.
Note Internet Explorer 6 is included with Windows XP. To add or remove Internet Explorer 6, you must click Start, click Control Panel, click Add/Remove, and then click Add/Remove windows components. If you are using the version of Internet Explorer that is included with your operating system, reinstall or repair your operating system.

For more information about how to reinstall or repair Internet Explorer in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
318378 How to reinstall or repair Internet Explorer in Windows XP
For more information about how to perform an in-place upgrade (reinstallation) of Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
315341 How to perform an in-place upgrade (reinstallation) of Windows XP
If the issue continues to occur, continue to the next method.

Remove and Reinstall Internet Explorer

If you cannot repair your installation of Internet Explorer, remove Internet Explorer, and then reinstall it. To do this, use the following methods in the order that they appear.

Remove Internet Explorer

Note You must have administrative credentials to install and remove Internet Explorer in Microsoft Windows 2000. This includes having administrative credentials the first time you start your computer after you install or remove Internet Explorer 5.5.

To remove Internet Explorer, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. On the Install/Uninstall tab, click Microsoft Internet Explorer and Internet Tools in the list of installed programs, and then click Add/Remove.

    Note If Microsoft Internet Explorer and Internet Tools is missing from the list of installed programs, run Setup.exe from your Internet Explorer\Setup folder. If you are running Windows 2000, run the w2kexcp.exe /u command from your Internet Explorer\IE Uninstall folder.
  4. Click Restore the previous Windows configuration, and then click OK.
  5. In the Internet Explorer and Internet Tools Setup dialog box, click OK to restore the previous version of Internet Explorer.
  6. When you are prompted to verify that you want to restore the previous version, click Yes.
  7. When you are prompted to restart the computer, do so.

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Workaround

To work around this problem, run Setup with the following command line:
Setup ACCEPTEULA=1
To do this, follow these steps:
  1. Click Start, click Run, type officeinstall_source_path\SETUP ACCEPTEULA=1 , and then press ENTER.

    Noteofficeinstall_source_path is the path to the location of the Office installation program Setup.exe.
  2. Click OK to start the Office installation.
Note This workaround may let you install Office 2003. However, the installation issue may persist when you try to reinstall Office 2003 or when you try to install updates. We recommended that you follow the procedures that are outlined in this article to resolve the issue.

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Keywords: kbsetup, kbprb, KB820930, kbwindowsinstaller, kberrmsg, kbxml

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Article Info
Article ID : 820930
Revision : 0
Created on : 9/12/2011
Published on : 9/12/2011
Exists online : False
Views : 447