Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Some Antivirus Programs May Cause Web Applications to Restart Unexpectedly


View products that this article applies to.


For a Microsoft .NET Framework 1.1 version of this article, see 821438.

↑ Back to the top


Symptoms

Some antivirus programs may cause Web applications to restart unexpectedly. If your computer is experiencing this problem, you may notice the following:
  • The Web applications or Application Domains (AppDomains) restart, although you have not changed any critical files. Critical files include the Web.config file, the Global.asax file, or any files in the Bin folder. (Each Web application is assigned to a single AppDomain.)
  • The AppDomain restarts cause the value of the ASP.NET Application Restarts Performance Monitor counter to increase.
  • The AppDomain restarts cause sessions to restart if you are using the InProc session state mode.
  • The AppDomain restarts may cause slow performance.

↑ Back to the top


Cause

Some antivirus programs change the archive bit of a file. Others change the creation date or the time that the file was last written to. If any of these changes occur on one of the critical files or folders, ASP.NET detects the change, and then restarts the AppDomain.

↑ Back to the top


Resolution

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next .NET Framework 1.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size       File name
   --------------------------------------------------------------
   10-Jun-2003  16:45  1.0.3705.433    200,704  Aspnet_isapi.dll
   10-Jun-2003  16:38                    4,169  Aspnet_perf.h
   10-Jun-2003  16:45                  513,302  Aspnet_perf.ini
   10-Jun-2003  16:45                  510,714  Aspnet_perf2.ini
   10-Jun-2003  16:45  1.0.3705.433     28,672  Aspnet_rc.dll
   10-Jun-2003  16:45  1.0.3705.433     24,576  Aspnet_regiis.exe
   10-Jun-2003  16:45  1.0.3705.433     28,672  Aspnet_wp.exe
   10-Jun-2003  16:07  1.0.3705.433     69,632  Corperfmonext.dll
   10-Jun-2003  16:05  1.0.3705.433    303,104  Mscorjit.dll
   12-Jun-2003  03:13  1.0.3705.433  1,953,792  Mscorlib.dll
   09-Jun-2003  18:52                   10,284  Mscorlib.ldo
   10-Jun-2003  16:06  1.0.3705.433  2,269,184  Mscorsvr.dll
   10-Jun-2003  16:06  1.0.3705.433  2,269,184  Mscorwks.dll
   01-Aug-2002  14:38                       15  Smartnav.htm
   17-Oct-2002  10:55                    8,728  Smartnav.js
   12-Jun-2003  03:15  1.0.3705.433  1,196,032  System.web.dll

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


More information

This hotfix has been tested for use with antivirus programs from the following third-party companies:
  • ETrust
  • McAfee
  • Symantec\Norton
Note Symantec has a fix available for on-demand scanning. This fix enables on-demand scanning to run without causing an AppDomain restart. Real-time scanning does not cause this problem.

↑ Back to the top


Article Info
Article ID : 820746
Revision : 8
Created on : 1/1/0001
Published on : 1/1/0001
Exists online : False
Views : 568