Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Slow Performance When You Use Internet Explorer 6 SP1 to View MIME Type File Attachments


View products that this article applies to.

Symptoms

When you use Internet Explorer 6.0 Service Pack 1 (SP1) to view a MIME type file attachment that is handled by a custom ActiveX control, it may take a long time to view the file, particularly if the file is very large. This behavior is different from what you experience in Internet Explorer 6.0 and earlier in the same scenario.

↑ Back to the top


Cause

Internet Explorer 6.0 and earlier versions create an instance of the ActiveX control before the file is downloaded to the cache. However, in Internet Explorer 6.0 SP1, the file is downloaded to the cache immediately -- before an instance of the ActiveX control is created. For performance reasons, this behavior is not optimal, particularly when you view large files. This issue is a side-effect of the hotfix that is described in the following Microsoft Knowledge Base article:
310388� Data for a POST Request Is Not Downloaded Completely in a Custom MIME Viewer

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   26-Sep-2003  15:32  6.0.2800.1267  484,352  Urlmon.dll
Note You must reinstall this hotfix after you install the cumulative patch for Internet Explorer that is described in Microsoft Knowledge Base (KB) article 828750.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
828750� MS03-040: October, 2003, Cumulative Patch for Internet Explorer
MS03-040: October, 2003, Cumulative Patch for Internet Explorer (828750) After you install this hotfix, the controls that handle the download must set the following DWORD value in the registry to a binary value of 1 under the following registry key:
HKEY_CLASSES_ROOT\CLSID\<clsid of the MIME type viewer>\NeedProgressiveDownload
Internet Explorer creates an instance of the control immediately, and then the control can either abort the current download and start a new one or try to bind to the current URL or cache file that is provided.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6 Service Pack 1.

↑ Back to the top


More information

Before the hotfix that is described in Knowledge Base article 310388 is installed, any POST request on a large file that is handled by a custom ActiveX control fails. This issue occurs because Internet Explorer tries to create an instance of the control immediately. Then, it tries to bind to the cache file, but the cache file does not exist because not all the data was downloaded. After you install this hotfix, Internet Explorer downloads the data up front before it creates an instance of the control.

↑ Back to the top


Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbqfe, kbqfe, kbie600sp2fix, kbie600presp2fix, kbbug, kbfix, kbhotfixserver, KB818857

↑ Back to the top

Article Info
Article ID : 818857
Revision : 11
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 299