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Long delay in the display of file names from the "Open" dialog box in Office XP


View products that this article applies to.

Symptoms

When you click Open (on the File menu or on the Standard toolbar) in a Microsoft Office XP program, the Open dialog box may delay the display of files for approximately 2 to 5 minutes.

Also, the processor (CPU) activity may indicate 100 percent utilization.

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Cause

This problem may occur when you try to locate a network drive or share that contains many folders and files.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Office XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP service pack

Hotfix information

Part 1: Download and install the hotfix

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date           Time     Size       File name     
   ------------------------------------------------
   29-Apr-2003  10:27     3,945,132  Sharedop.msp
   29-Apr-2003  15:04    10,140,948  Sharedff.msp
the following files will have the file attributes (or later) that are listed in the following table.
   Date         Time   Version       Size       File name     
   -------------------------------------------------------
   28-Apr-2003  23:27  10.0.5222.0   9,939,528  Mso.dll 
				

Part 2: Enable the hotfix

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To enable this hotfix, follow these steps:
  1. Quit all Microsoft Office programs.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common\Open Find
  4. After you select the key that is specified in step 3, point to New on the Edit menu, and then click DWORD.
  5. Type DisableAutoSelect, and then press ENTER.
  6. Right-click DisableAutoSelect, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. On the File menu, click Exit to quit Registry Editor.

Note With this hotfix enabled, the Microsoft Visual Basic for Applications code that uses the SelectedItems property will not function as expected because the hotfix no longer selects the first file.

Note The Multiple Directory View, FTP, and History views of the File Open dialog box are not affected when you enable the DisableAutoSelect registry key.

This hotfix is a post-Office XP Service Pack 2 (SP-2) hotfix. To install the hotfix, you must have Office XP SP-2 installed. For more information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:
325671 Description of the Office XP Service Pack 2 (SP2)
Additionally, you may have to install Windows Installer 2.0 to install this hotfix. For more information about the Windows Installer requirement for post-Office XP SP-2 hotfixes, click the following article number to see the article in the Microsoft Knowledge Base:
330537 Office XP updates and patches released after September 2002 may require Windows Installer 2.0

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Office XP Service Pack 3.

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Keywords: KB818792, kbofficexppresp3fix, kbfix, kbbug, kbperformance, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 818792
Revision : 9
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 294