Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XCCC: Performance Temporarily Decreases on the Server When the WebDAV GET Method Is Called For a Message


View products that this article applies to.

Symptoms

When you use a program that calls the Web Distributed Authoring and Versioning (WebDAV) GET method on a message that is stored on an Exchange 2000 computer, you may find that the performance of the computer may temporarily decrease. If you create a counter log in Performance Logs and Alerts to monitor the PhysicalDisk object, a spike occurs in the Avg.Disk Write Queue Length counter.

↑ Back to the top


Cause

This problem may occur in situations when the message contains a large attachment. For example, this problem may occur if the message contains an attachment that is 15 megabytes (MB). When the WebDAV GET method is called for a message, a temporary file is created for the message in the %SysemRoot%\Temp folder on the computer. When the size of the message (including the attachment) is large, performance may temporarily decrease during the time that it takes for the computer to process the request.

↑ Back to the top


Resolution

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824282� September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378� How to Obtain the Latest Exchange 2000 Server Service Pack

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Component: Information Store
   Date         Time   Version     Size       File name
   -------------------------------------------------------
   04-Jun-2003  00:46  6.0.6472.0  3,915,776  Cdoex.dll        
   04-Jun-2003  00:40  6.0.6472.0    827,392  Davex.dll        
   04-Jun-2003  00:38  6.0.6472.0    577,536  Dsaccess.dll     
   03-Jun-2003  23:47  6.0.6472.0    184,320  Dscmsg.dll       
   04-Jun-2003  00:46  6.0.6472.0  3,575,808  Excdo.dll        
   04-Jun-2003  00:38  6.0.6472.0    258,048  Exmime.dll       
   04-Jun-2003  00:40  6.0.6472.0  2,138,112  Exoledb.dll      
   04-Jun-2003  00:36  6.0.6472.0     81,920  Exosal.dll       
   04-Jun-2003  00:40  6.0.6472.0    307,200  Exprox.dll       
   03-Jun-2003  23:39  6.0.6472.0     49,152  Mdbevent.dll     
   04-Jun-2003  00:08  6.0.6472.0  2,285,568  Mdbmsg.dll       
   03-Jun-2003  23:41  6.0.6472.0     32,768  Mdbrole.dll      
   04-Jun-2003  00:38  6.0.6472.0     24,576  Mdbtask.dll      
   04-Jun-2003  00:37  6.0.6472.0  4,648,960  Store.exe

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: KB818723, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 818723
Revision : 8
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 319