Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: SNA LU6.2 Resync service does not succeed when the Remote LU is unavailable


View products that this article applies to.

Symptoms

If the SNA LU6.2 Resync service does not successfully ALLOCATE a conversation with one Remote logical unit (LU), requests for all Remote LUs that require syncpoint (2PC) may not succeed.

In the application event log of the system that is running the SNA Server service, an Event ID 18 generally appears. This EventID 18 indicates a BIND failure, and is followed by an Event ID 110. This Event ID 110 is logged in the application event log of the system that is running the SNA LU6.2 Resync Service, and will be similar to the following:

(110) The Resynchronization Service failed to allocate a conversation with the Remote LU.

EXPLANATION:
The Resynchronization Service could not communicate with the remote logical unit (host LU) REMLU1 to prepare for transactions with it from local LU LOCAL1.

In SNA Application API traces, all APPC calls that are made by the SNA LU6.2 Resync service after the ALLOCATE error do not succeed and have a primary return code of 0xf003 (AP_COMM_SUBSYSTEM_ABENDED).

↑ Back to the top


Cause

This problem occurs because the APPC library is incorrectly issuing a CLOSE_TP message when an ALLOCATE request does not succeed due to a BIND failure. After the CLOSE_TP request has been issued, the connection with the SNA Server service is lost and all further APPC calls are unsuccessful and have the primary return code of 0xf003 (AP_COMM_SUBSYSTEM_ABENDED).

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Host Integration Server 2000 and Host Integration Server 2000 Administrator Client

   Date         Time   Version      Size    File name
   ------------------------------------------------------
   10-Mar-2003  12:21  5.0.0.900   221,456  Wappc32.dll
				

Host Integration Server 2000 End-User client

   Date         Time   Version     Size    File name
   ------------------------------------------------------
   10-Mar-2003  12:21  5.0.0.900  155,920  Wappc32.dll
				

NOTE: Because of file dependencies, the most recent fix that contains the preceding files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Host Integration Server 2000 and Host Integration Server 2000 Service Pack 1.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

↑ Back to the top


More information

If COMTI is the application that requires a syncpoint (2PC) conversation, an Event ID 102 is logged each time that COMTI tries to ALLOCATE a conversation after the SNA LU6.2 Resync service enters the failed state.

The event 102 will be similar to the following:

(102) COM Transaction Integrator reported the following exception to the client:

Component: Component.Interface.1
Method: Method1

Exception description: (1227) COM Transaction Integrator was unable to enlist on the DTC transaction (HRESULT=0x8004d10d). If HRESULT is 8004d10E or 8004d10F, retry the request. If HRESULT is 8004d110, the transaction recovery has failed. Use the DTC Admin Console to manually resolve any pending transactions. For all other HRESULTs, start the COM Transaction Integrator Resynchronization Service. If COMTI Resynchronization Service is already active, contact Microsoft customer support.

↑ Back to the top


Keywords: KB815308, kbbug, kbfix, kbqfe, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 815308
Revision : 4
Created on : 2/20/2007
Published on : 2/20/2007
Exists online : False
Views : 423