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Text Box Fields Do Not Accept Special Characters When Layout Settings Are Set to Certain Languages


View products that this article applies to.

Symptoms

When the keyboard layout and settings are set to French, German, or any other language that uses marked characters, text box fields such as User name and Password at the advanced channel properties do not accept special characters such as the at sign (@) and backslash (\).

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Cause

The pages are blocking these keys because the AltGr key is sending a ctrlKey pressed event.

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Resolution

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft BizTalk Server 2002. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
815781 How to Obtain the Latest BizTalk Server 2002 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem described in this article. Only apply it to systems that are experiencing this specific problem. This fix may receive additional testing to further ensure product quality. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Service Pack 1 that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date        Time   Version        Size  File name
------------------------------------------------------- 
22-Jan-2003 17:14  3.0.1558.0  901,392  Btmdesk.ocx
22-Jan-2003 16:35                4,037  Pe_dlg_util.asp

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Workaround

To work around this problem, do either of the following:
  • Add an additional US keyboard layout to your system and switch to US keyboard layout to enter those characters.
  • Copy the character from a text editor:
    1. In Notepad or another text editor, type the character that you want to use. For example, you may want to use the at sign (@) or the backslash (\).
    2. Copy the character from the text editor, and then paste the character in the User Name text box or the Password text box.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft BizTalk Server 2002 Service Pack 1.

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Keywords: KB813320, kbfix, kbbiztalk2002sp1fix

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Article Info
Article ID : 813320
Revision : 6
Created on : 10/6/2005
Published on : 10/6/2005
Exists online : False
Views : 384