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Exchange user unexpectedly receives a standard NDR instead of a custom NDR


View products that this article applies to.

Symptoms

When a Microsoft Exchange 2000 Server user or a Microsoft Exchange Server 2003 user composes and sends a message to a recipient on an external domain that is configured to use a custom non-delivery report (NDR), if the address of the recipient is non-deliverable, the Exchange user may not receive the custom NDR as expected. Instead, the Exchange user receives a standard NDR in Microsoft Outlook that is similar to the following:
From: System Administrator

To: Sender
Subject: Undeliverable: Subject

Your message did not reach some or all of the intended recipients.

Subject: Subject
Sent: Date and Time

The following recipient(s) could not be reached:

RecipientAddress on Date and Time

The e-mail account does not exist at the organization this message was sent to. Check the e-mail address, or contact the recipient directly to find out the correct address.

<Domain #5.1.1>

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Cause

This issue occurs because when you use a MAPI client to open and view an NDR, the NDR is reformatted by the Exchange 2000 or Exchange 2003 information store, and any customization that the NDR contains is lost. If you access the message from a non-MAPI client, the customizations that are contained in the NDR are retained.

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Resolution

Cumulative rollup information for Exchange 2000

To resolve this problem in Exchange 2000, obtain the September 2003 Exchange 2000 Server post-Service Pack 3 (SP3) Rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824282 September 2003 Exchange 2000 Server post-Service Pack 3 Rollup
After you install the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup, edit the registry to add the
RenderDSNsAsMessages
DWORD value to the following registry subkey on the server:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
To do this, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type RenderDSNsAsMessages, and then press ENTER.

    Important Make sure that you choose a REG_DWORD value type.
  6. On the Edit menu, click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Quit Registry Editor.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Component: Information store

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size    File name
--------------------------------------------------------
09-Jan-2003  18:44  6.0.6397.0   3,915,776  Cdoex.dll        
09-Jan-2003  18:18  6.0.6397.0     131,072  Drviis.dll       
09-Jan-2003  18:44  6.0.6397.0   3,571,712  Excdo.dll        
09-Jan-2003  18:19  6.0.6397.0     258,048  Exmime.dll       
09-Jan-2003  18:36  6.0.6397.0   1,691,648  Exoledb.dll      
09-Jan-2003  18:36  6.0.6397.0     303,104  Exsmtp.dll       
09-Jan-2003  17:48  6.0.6397.0   2,260,992  Mdbmsg.dll       
09-Jan-2003  17:19  6.0.6397.0      32,768  Mdbrole.dll      
09-Jan-2003  18:15  6.0.6397.0      94,208  Peexch50.dll     
09-Jan-2003  18:16  6.0.6397.0     393,216  Phatcat.dll      
09-Jan-2003  18:18  6.0.6397.0   4,591,616  Store.exe    
Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack
After you install the hotfix, edit the registry to add the
RenderDSNsAsMessages
DWORD value to the following registry subkey on the server:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
To do this, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type RenderDSNsAsMessages, and then press ENTER.
  6. On the Edit menu, click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Quit Registry Editor.


Information for Exchange 2003

Exchange 2003 supports the following registry subkey. Therefore, you do not have to apply the hotfix that is mentioned for Exchange 2000. To resolve this problem in Exchange 2003, edit the registry to add the
RenderDSNsAsMessages
DWORD value to the following registry subkey on the server:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
To do this, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
  4. On the Edit menu, click New, and then click DWORD Value.
  5. Type RenderDSNsAsMessages, and then press ENTER.
  6. On the Edit menu, click Modify.
  7. In the Value data box, type 1, click Decimal under Base, and then click OK.
  8. Quit Registry Editor.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB812806, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 812806
Revision : 11
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 677