Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Page cannot be displayed" error message when you open an .eml attachment in Outlook Web Access


View products that this article applies to.

Symptoms

When you compose and then send a message that contains an .eml file attachment in Microsoft Outlook, the recipient may receive an error message if the recipient uses Microsoft Outlook Web Access (OWA) to open the .eml attachment. The error message is similar to the following error message:
The page cannot be displayed.
The page you are trying to reach cannot be retrieved.
--------------------------------------------------------------------------------
Please try the following:
Open the localhost home page, and then look for links to the information you want.
Click the Refresh button, or try again later. Click Search to look for information on the Internet. You can also see a list of related sites.

Error 501/505 - Not implemented or not supported
Internet Explorer

↑ Back to the top


Cause

This problem may occur if all the following conditions are true:
  • You configure the Send clear text signed message when sending messages option in Outlook.
  • The message is digitally signed by using clear text.
  • You attach an .eml file to the message.

↑ Back to the top


Resolution

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824282 September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
301378 How to Obtain the Latest Exchange 2000 Server Service Pack

File Information

Component: OWA

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version        Size    File name
----------------------------------------------------------
09-Jun-2003  20:49  6.0.6474.0  3,915,776  Cdoex.dll        
09-Jun-2003  20:43  6.0.6474.0    827,392  Davex.dll        
09-Jun-2003  20:38  6.0.6474.0    577,536  Dsaccess.dll     
09-Jun-2003  19:44  6.0.6474.0    184,320  Dscmsg.dll       
09-Jun-2003  19:54  6.0.6474.0    958,464  Emsmdb32.dll     
09-Jun-2003  20:49  6.0.6474.0  3,575,808  Excdo.dll        
09-Jun-2003  20:38  6.0.6474.0    258,048  Exmime.dll       
09-Jun-2003  20:43  6.0.6474.0  2,138,112  Exoledb.dll      
09-Jun-2003  20:35  6.0.6474.0     81,920  Exosal.dll       
09-Jun-2003  20:43  6.0.6474.0    307,200  Exprox.dll      
12-May-2003  18:40                  8,985  Frm_readnote20.js
09-Jun-2003  19:33  6.0.6474.0     49,152  Mdbevent.dll     
09-Jun-2003  19:51  6.0.6474.0  2,285,568  Mdbmsg.dll       
09-Jun-2003  19:34  6.0.6474.0     32,768  Mdbrole.dll      
09-Jun-2003  20:39  6.0.6474.0     24,576  Mdbtask.dll      
09-Jun-2003  20:37  6.0.6474.0  4,648,960  Store.exe        
12-May-2003  18:40                 22,121  Util_owa20.js
09-Jun-2003  19:51  6.0.6474.0  3,735,552  Wmtemplates.dll     
After you apply this hotfix, you must enable the functionality of the hotfix. To do so, add the
AllowEmbeddedMessageSave
DWORD value to the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA
To add the DWORD value, follow these steps.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type AllowEmbeddedMessageSave, and then press ENTER.
  6. On the Edit menu, click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Quit Registry Editor.
After you add the DWORD value to the registry key, you can do the following:
  • When you open the message and then click the .eml attachment, the .eml file opens.
  • When you open the message and right-click the .eml attachment, and then click either Open or Open in New Window, the .eml file opens in a new Web browser window.
  • When you open the message and right-click the .eml attachment, and then click Save Target As, the Save As dialog box appears. In the Save As dialog box, you can specify a file name and a location where you want to save the .eml file.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: KB812658, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 812658
Revision : 8
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 315