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It may take 35 seconds to delete files over the network


View products that this article applies to.

Symptoms

It may take approximately 35 seconds to delete files over the network. This problem occurs approximately 10 to 15 percent of the time. A network trace of the problem shows the following frames:
Client -> Server - C NT Create & X, File : \test.txt - request for OpLock\OpBatch
Client -> Server - C Delete File, File = : \test.txt
Server -> Client - R NT Create &X, FID = 0x8003 - oplock level = Batch
Server -> Client - C Lock - Break Oplock
A delay of approximately 35 seconds occurs at this time.
Server -> Client - R Delete Status_Sharing_Violation
Client -> Server - C Lock & X, FID = 0x8003 - Break OpLock
Client -> Server - C Delete File, File = : \test.txt
Server -> Client - R Delete
The first two frames are from the client. The initial frame is an "NT Create" message with a request for Oplock/OpBatch for the file. This is followed by the "Delete" request for the same file. The next frame is the server's response to the "NT Create" request with a Oplock level of "batch." The server then sends a Break OpLock message for the previous frame so that it can delete the file. The server then waits 35 seconds (until its OpLockBreakWait time-out value has expired) before the deletion does not work. The client can then release the lock and try the deletion again.

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Cause

When the Break Oplock request is received by the client, the client cannot process the request because it is already waiting on the Delete request. The server cannot handle the Delete request until the Oplock on the file has been released. This causes a pseudo-deadlock condition that is broken after the server's OpLockBreakWait time-out value expires.

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Resolution

Windows XP service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix is replaced by the hotfix that is documented in the following article in the Microsoft Knowledge Base: For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
885451� A 35-second delay occurs when you delete a file that is located on a network share in Windows Server 2003

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name   Platform
   ----------------------------------------------------------------
   26-Jun-2003  20:44  5.2.3790.67    393,728  Mrxsmb.sys  x86
   26-Jun-2003  20:44  5.2.3790.67    157,184  Rdbss.sys   x86
   26-Jun-2003  20:44  5.2.3790.67  1,121,792  Mrxsmb.sys  IA-64
   26-Jun-2003  20:44  5.2.3790.67    462,336  Rdbss.sys   IA-64

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows XP Service Pack 1.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version          Size     File name   Platform
   ------------------------------------------------------------------
   30-Jan-2003  16:41  5.1.2600.1164    400,896  Mrxsmb.sys  x86
   30-Jan-2003  16:41  5.1.2600.1164    154,880  Rdbss.sys   x86
   30-Jan-2003  16:41  5.1.2600.1164  1,259,392  Mrxsmb.sys  IA-64
   30-Jan-2003  16:41  5.1.2600.1164    489,216  Rdbss.sys   IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbwinxpsp2fix, kbqfe, kbwinxppresp2fix, kbfix, kbbug, KB811492

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Article Info
Article ID : 811492
Revision : 16
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 591