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XADM: Extensible Storage Engine Event IDs 474 and 477 Are Logged When You Try to Back Up the Information Store Database


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Summary

When you try to back up your Microsoft Exchange Server 2003 or Microsoft Exchange 2000 Server Information Store database by using an Exchange online backup, you may experience one or more of the following symptoms:
  • Events that are similar to the following may be listed in the application log in Event Viewer:

    Date: date
    Source: ESE
    Time: time
    Category: (3)
    Type: Error
    Event ID: 477
    User: N/A
    Computer: Servername
    Description: Information Store (1556) The log range read from the file "D:\Program Files\exchsrvr\mdbdata\First Storage Group\E0000001.log" at offset 2736128 (0x000000000029c000) for 3072 (0x00000c00) bytes failed verification due to a range checksum mismatch. The read operation will fail with error -612 (0xfffffd9c). If this condition persists then please restore the log file from a previous backup.



    Date: date
    Source: ESE
    Time: time
    Category:
    Type: Error
    Event ID: 474
    User: N/A
    Computer: Servername
    Description: Information Store (2240) The database page read from the file "E:\program files\exchsrvr\mdbdata\priv1.edb" at offset 204275712 (0x000000000c2d0000) for 4096 (0x00001000) bytes failed verification due to a page checksum mismatch. The expected checksum was 303571876 (0x121823a4) and the actual checksum was 303571940 (0x121823e4). The read operation will fail with error -1018 (0xfffffc06). If this condition persists then please restore the database from a previous backup.

  • If you use the NTBackup program that is included with Microsoft Windows 2000 Server, the following information may be listed in the backup log file:
    Backup Status
    Operation: Backup
    Active backup destination: File
    Media name: "Media created 8/21/2002 at 11:17 AM"
    
    Backup of "Servername\Microsoft Information Store\First Storage Group"
    Backup set #1 on media #1
    Backup description: "Set created 8/21/2002 at 11:17 AM"
    Backup Type: Normal
    
    Backup started on 8/21/2002 at 11:17 AM.
    WARNING: Portions of "\Log Files" cannot be read. The backed up data is corrupt or
    incomplete.
    This file will not restore correctly.
    Backup completed on 8/21/2002 at 11:18 AM.
    Directories: 6
    Files: 9
    Bytes: 892,028,562
    Time:  1 minute and 23 seconds
  • The system log in Event Viewer may contain events that indicate input/output (I/O) errors, hard disk controller errors, or hard disk errors.

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Cause

These issues occur because of a defective hard disk subsystem hardware component or because of outdated or incompatible drivers or firmware in the hard disk subsystem.
  • The -612 (Jet_errLogReadVerifyFailure) error occurs when a checksum error occurs in a log file during backup.
  • The -1018 (JET_errReadVerifyFailure) error occurs when a checksum error occurs on a database page.
The -1018 (JET_errReadVerifyFailure) error is more frequently seen and indicates that an Exchange database has suffered damage at the file system level. This error is caused by a problem in the disk subsystem. The problem in the disk subsystem may be caused by defective disk drives, by outdated or incompatible disk drive firmware, or by outdated or incompatible controller firmware. Sometimes, too much heat around the disk drive subsystem components may cause this error. Damage may occur to the Exchange database in the following three ways:
  • Incorrect data is written to the storage media.
  • Data is written to an incorrect location on the storage media.
  • Data is damaged or changed after the data is written to the storage media.
Microsoft Exchange 2000 detects both incorrect data and misplaced data in its database files and reports a -1018 error or a -1019 error. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
314917 XADM: Understanding and analyzing -1018, -1019, and -1022 Exchange database errors

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Resolution

To resolve these issues, follow these steps:
  1. If you can, test the backup procedure on a new storage group or on a test storage group that has new blank databases and log files that are located on different physical hard disks on the server. This helps to minimize the number of affected components to troubleshoot.
  2. Run all the manufacturer-supplied hardware diagnostics on the server to determine if there is a problem with a hardware device; especially with hardware devices that are part of the disk subsystem.
  3. Try to obtain firmware updates and driver updates for the hard disk controllers in the server.
  4. Restore the database from an online backup. If you do not have a backup that you can use, perform a hard repair operation on the database. For additional information about how to recover from Exchange database error -1018, click the following article number to view the article in the Microsoft Knowledge Base:
    314917 XADM: Understanding and analyzing -1018, -1019, and -1022 Exchange database errors
    For more information about how to perform a hard repair of a database, click the following article number to view the article in the Microsoft Knowledge Base:
    259851 Ramifications of running the eseutil /p or edbutil /d /r command in Exchange

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More information

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
327334 XADM: Event ID 474 error indicates a hardware failure
314917 XADM: Understanding and analyzing -1018, -1019, and -1022 Exchange database errors
151789 XADM: Error -1018 (JET_errReadVerifyFailure)
For additional information about how to recover an Exchange 2000 database, click the following article numbers to view the articles in the Microsoft Knowledge Base:
301460 Exchange command-line parameters for the Isinteg.exe tool
296788 Offline backup and restoration procedures for Exchange
317014 XADM: Exchange 2000 Server Eseutil command line switches
192185 XADM: How to defragment with the Eseutil utility (Eseutil.exe)
265441 XADM: Some questions and answers about the Exmerge utility
174197 XADM: Microsoft Exchange Mailbox Merge Program (Exmerge.exe) information
259851 Ramifications of running the eseutil /p or edbutil /d /r command in Exchange
272570 XADM: How to Recover from Information Store Corruption
282496 XADM: Considerations and best practices when resetting an Exchange mailbox database
259688 XADM: How to use the Exmerge utility to extract data from a damaged database
For additional information about Exchange 2000 disaster recovery, read the "Disaster Recovery for Microsoft Exchange 2000 Server" document. To obtain this document, visit the following Microsoft Web site:

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Keywords: KB810411, kbinfo

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Article Info
Article ID : 810411
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 362