Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You can't delete a web app that's deployed as "Required" from Intune


View products that this article applies to.

Symptoms

Consider the following scenario:

  • You have a web app that's deployed as Required to iOS or Android devices in a hybrid MDM environment that includes Microsoft Intune and Configuration Manager.
  • You migrate users and devices to Intune standalone.
  • After the migration, you try to delete the web app as a managed app, or you change the app assignment type to Uninstall.

In this scenario, the web app can't be deleted. Additionally, users can't delete the web app from their devices.

↑ Back to the top


Cause

The behavior is expected. After you migrate from hybrid MDM to Intune standalone, the web app identifier is no longer available. Therefore, the web app can't be deleted. For more information, see Add web apps to Microsoft Intune.

↑ Back to the top


Workaround

To work around the issue, use one of the following methods:

  • Delete the web app from devices before the migration, then redeploy the app after the migration.
  • After the migration, change the app assignment type to Available for enrolled devices, and then instruct users to reinstall the app after the next device sync.

    Note Users can start a manual device sync from the Company Portal app on their devices to speed up this process.

After the app is reinstalled as Available for enrolled devices, it can be successfully deleted from Intune or the user devices.

↑ Back to the top


Keywords: InTune, Manage Apps, kbContentAuto, kbSupportTopic, delete web app intune

↑ Back to the top

Article Info
Article ID : 4463893
Revision : 15
Created on : 8/8/2019
Published on : 8/8/2019
Exists online : False
Views : 376