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"Missing certificate" when you sign in to the Company Portal app on an Android device


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Symptoms

When you try to sign in to the Company Portal app on an Android device, you receive the following error message: 

file_Symptoms_image1.png

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Cause

This issue occurs if Active Directory Federation Services (AD FS) is used for certificate authentication, and the intermediate certificate isn't installed on the AD FS server and Web Application Proxy (WAP) server.

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Resolution

To fix the issue, follow these steps on all AD FS and WAP servers to install the intermediate certificate:

  1. Open the Certificate Management console. To do this, type certlm.msc in the Run dialog box.
  2. Expand Certificates (Local Computer) > Personal, and then click Certificates.
  3. Right-click the AD FS service communications certificate, and then click Properties.
  4. Select the Certification Path tab to view the certificate chain.
  5. For each parent certificate, do the following:
    1. Select the certificate, and then click View Certificate.
    2. Select the Details tab, and then select Copy to file.
    3. Follow the wizard to export or save the certificate public key to the desired file location.
  6. Import each of the parent certificates that were exported in step 5 to the corresponding certificate store. For example, import the root certificate to the Trusted Root Certification Authorities store, and import the intermediate certificate to the Intermediate Certification Authorities store.
  7. Restart the server.

You can run the following command to dump a certificate store so that you can determine whether the certificates are installed correctly:

CertUtil -v -store <CertificateStoreName> > <OutputFile>

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More Information

You can use SSL Certificate Checker to test whether the certificate is installed correctly on the server.

If the intermediate certificate isn't installed correctly, you receive the following message in the result: 

4136923 image 1

If the intermediate certificate is installed correctly, you receive the following message in the result: 

4136923 image 2

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Keywords: kbContentAuto, kbTFSImage, missing certificate, sign in company portal

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Article Info
Article ID : 4136923
Revision : 10
Created on : 7/9/2018
Published on : 7/9/2018
Exists online : False
Views : 836