Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Can't retrieve time slot information about private calendar items as a delegate on another user's account in Exchange Server 2016


View products that this article applies to.

Symptoms

Consider the following scenario:

  • You use the Windows or Outlook for Mac client to connect to Exchange Server 2016.
  • You are assigned as a delegate on another user's account.
  • The Delegate can see my private items option is enabled on the user's account.
  • Some calendar items are marked as "Private" on the user's account.

In this scenario, you can't retrieve correct free/busy information about the user's account. In this case, the time slot information about "Private" items is presented as Free.

↑ Back to the top


Cause

This issue occurs because Exchange Web Services (EWS) calls do not return the items that are marked as Private.

↑ Back to the top


Resolution

Exchange Server 2016

To resolve this issue, install Cumulative Update 9 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

Learn about the terminology that Microsoft uses to describe software updates.

↑ Back to the top


Keywords: kbNotAutoHotfix, kbQFE, kbfix, kbExpertiseInter, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 4058382
Revision : 19
Created on : 3/7/2018
Published on : 3/20/2018
Exists online : False
Views : 267