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MapPoint and AccessLinks Add-In for Excel Cause Errors to Occur and May Cause the Application to Stop Responding


View products that this article applies to.

This article was previously published under Q328280

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Symptoms

You may experience problems when you use the MapPoint tool. The problems may also occur when you click MapPoint Map on the Insert menu in Excel. In either case, whether you use the MapPoint tool to embed a map in a spreadsheet, or you click MapPoint Map to embed a map in a spreadsheet, you may receive the following error message:

There was a problem opening: path\filename.xls, sheetname!address
You may receive the same error message when you paste Excel data in a MapPoint map.

If you repeatedly use the embedded maps, this may cause both Excel and MapPoint to stop responding. You may also see one of the following error messages:
Microsoft Excel has encountered a problem and needs to close. We are sorry for the inconvenience.
Microsoft MapPoint has encountered a problem and needs to close. We are sorry for the inconvenience
When you export data to an existing Microsoft Access database, and you use the AccessLinks Add-In, the database opens, and then you may receive the following error message:

The Microsoft Jet database engine could not find the object path\filename.xls, sheetname!address

Make sure the object exists and that you spell its name and path name correctly.

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Cause

When the Microsoft Jet 4.0 database engine was updated to Service Pack 6, the Excel ISAM (Msexcl40.dll, version 4.0.5919.0) was included. This version of Msexcl40.dll was incompatible with the MapPoint add-in for Excel. The database engine was updated to this version when the stand-alone Microsoft Jet 4.0 Service Pack 6, Windows 2000 Service Pack 3, or Windows XP Service Pack 1 was installed.

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Resolution

To resolve this problem, obtain the latest Jet 4.0 Service Pack. The service pack contains an updated version of the Jet 4.0 database engine and the Excel ISAM driver.

For additional information about how to obtain the latest version of the Jet 4.0 database engine, click the following article number to view the article in the Microsoft Knowledge Base:
239114 How To: Obtain the Latest Service Pack for the Microsoft Jet 4.0 Database Engine

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first resolved in Jet 4.0 Service Pack 7 (SP7).

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Keywords: KB328280, kbhotfixserver, kbqfe, kbfix, kbbug

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Article Info
Article ID : 328280
Revision : 4
Created on : 9/27/2005
Published on : 9/27/2005
Exists online : False
Views : 371