Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The CDO for Exchange Management code stops responding and runtime error c00707ba is generated


View products that this article applies to.

This article was previously published under Q326391

↑ Back to the top


Symptoms

The CDO for Exchange Management (CDOEXM) code may stop responding in the DataSource.Open call. The following error is generated:
Runtime error '-1073281350 (c00706ba): Automation error

↑ Back to the top


Cause

This problem may occur if the domain name does not contain a period. The code behind the Open call incorrectly checks the domain name that is passed to see whether the domain name contains a period character (.). If the domain name does not contain a period, the call fails and the error is generated.

↑ Back to the top


Resolution

Cumulative Patch Information

To resolve this problem, obtain the March 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
813840 March 2003 Exchange 2000 Server post-Service Pack 3 (S813840) rollup

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. Component: CDO for Exchange Management The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time       Version      Size        File name
   -----------------------------------------------------------
   05-AUG-02   14:05:47   6.0.6308.0   2,105,344   Cdoexm.dll
  
				
NOTE: Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

↑ Back to the top


Keywords: KB326391, kbqfe, kbfix, kbexchange2000presp4fix, kberrmsg, kbbug, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 326391
Revision : 10
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 411