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FIX: Windows 98 SE Clients Cannot Connect to a Named Instance of SQL Server 2000 with MDAC 2.7


View products that this article applies to.

This article was previously published under Q325292

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Symptoms

Sometimes client computers that are running Microsoft Windows 98 Second Edition (SE), and that use MDAC 2.7, cannot connect to a named instance if Microsoft SQL Server 2000. Instead, they may receive the following connection error message:
[TCP/IP Sockets]Specified SQL server not found.
[TCP/IP Sockets]ConnectionOpen (Connect()).
OS Error 120 (null)

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Cause

As soon as the client computer sends a UDP request packet to SQL Server on port 1434, the client computer waits for a fixed period of time to receive a UDP response packet back from SQL Server. This timeout is a safeguard against lost UDP packets because UDP is a connectionless protocol that does not guarantee packet delivery. If the time that it takes to receive the UDP response packet from the server is greater than the fixed period of time that the client computer waits to receive the packet, the connection cannot be established with SQL Server.

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Resolution

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next MDAC 2.7 SP2 that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time         Version          Size      File name
   ----------------------------------------------------------------
   7/16/2002  4:17:54 PM  2000.81.9001.12 61,440 bytes Dbnetlib.dll
				

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Workaround

Use SQL Server Client Network Utility tool to create an alias on the client-side, and specify the connection information.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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More information

The time that SQL Server takes to send the UDP response packet exceeds the fixed timeout that is set by the network library to receive the UDP response packet. The fixed timeout is few hundred milliseconds (ms).

Steps to Reproduce the Behavior

  1. On a computer that is running Windows 98 SE, install SQL Server 2000.
  2. In the Installation Definition dialog box of the SQL Server Installation Wizard, click Client Tools Only.
  3. In the Select Components dialog box, click to select only Management Tools and Client Connectivity.
  4. Make sure that the client is configured to run using Domain Name System (DNS) only, and not Windows Internet Name Service (WINS).
  5. Make sure that the following registry key is cleared:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\Client\SuperSocketNetLib\LastConnect
    NOTE: If the registry key is not cleared, the network libraries do not send the UDP request and use the cached information.

  6. Use osql from the client to connect to a named instance of SQL Server 2000:
      > osql -MyServer1\inst1 -E
     
    					
  7. If the network latency between the client and the server is greater than 500 ms, the client cannot connect.
  8. Install the hotfix. The client computer can now connect to the named instance.

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Keywords: KB325292, kbhotfixserver, kbqfe, kbfix, kbbug

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Article Info
Article ID : 325292
Revision : 5
Created on : 10/11/2005
Published on : 10/11/2005
Exists online : False
Views : 416