Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Excel stops responding when subtotals are removed


View products that this article applies to.

This article was previously published under Q324557
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When you try to remove subtotals from a cell range in Microsoft Excel 2002 or Excel 2003, the program may appear to stop responding (hang) with Excel consuming 100 percent of the processor time.

↑ Back to the top


Cause

In Excel 2002, data validation and conditional formatting were changed to adjust in a more intuitive manner. This change causes more splintering of the validation and formatting references in memory. Because of this, the existence of these extra references causes a corresponding slowdown in some operations.

↑ Back to the top


Resolution

Excel 2003

To resolve this issue in Excel 2003, add the following registry key. The fix is included in the initial release of Excel 2003. Therefore, there is no hotfix to download for this version of Excel.Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.To activate this hotfix, follow these steps:
  1. Quit Excel.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Options
  4. After you select the key that is specified in step 3, point to New on the Edit menu, and then click DWORD.
  5. Type QFE_Detroit, and then press ENTER.
  6. Right-click QFE_Detroit, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. On the File menu, click Exit to quit Registry Editor.

Excel 2002

Service Pack Information

This problem is corrected in Office XP Service Pack 3.To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841� How to obtain the latest Office XP Service Pack

Hotfix information

Part 1: Download and install the fix

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size        File name
   ------------------------------------------------------------
   10-Sep-2002  05:06  12,809,536  Excel.msp        (Client)
   10-Sep-2002  05:37  14,104,576  Excel_admin.msp  (Full File)
After the hotfix is installed, the Global version of this fix has the file attributes (or later) that are listed in the following table.
   Date         Time   Version      Size       File name
   -----------------------------------------------------
   06-Sep-2002  22:18  10.0.4503.0  9,177,672  Excel.exe

Important Information Before You Install the Hotfix

  • The Full-File version of this fix installs on Microsoft Office XP Service Pack 1 (SP-1). However, the Full-File version has not been tested to the same extent on that version as it has on Microsoft Office XP Service Pack 2 (SP-2). Some unanticipated file conflicts are possible. This configuration is supported, but not recommended.
  • The Client version of this fix is a post-Office XP SP-2 fix. To install the fix, you must have Office XP SP-2 installed. For additional information about Office XP SP-2, click the following article number to view the article in the Microsoft Knowledge Base:
    325671� OFFXP: Overview of the Office XP Service Pack 2
  • The Client version of this fix requires Windows Installer 2.0 or later. For additional information about the Windows Installer requirement, click the following article number to view the article in the Microsoft Knowledge Base:
    330537� OFFXP: Office XP Updates and Patches Released After September 2002 May Require Windows Installer 2.0


Part 2: Activate the Update

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To this hotfix, follow these steps:
  1. Quit Excel.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Excel\Options
  4. After you select the key that is specified in step 3, point to New on the Edit menu, and then click DWORD.
  5. Type QFE_Detroit, and then press ENTER.
  6. Right-click QFE_Detroit, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. On the File menu, click Exit to quit Registry Editor.

↑ Back to the top


Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Office XP Service Pack 3.

↑ Back to the top


Keywords: KB324557, kbfix, kbbug, kbofficexppresp3fix, kbhotfixserver, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 324557
Revision : 8
Created on : 2/1/2007
Published on : 2/1/2007
Exists online : False
Views : 482