Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Email message body is garbled when the Russian version of Outlook is used in Exchange Server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are running Microsoft Outlook in Online Mode in an Exchange Server or Office 365 environment.
  • The Preferred encoding for outgoing messagesoption in Outlook is set to KOI8-R (the default encoding setting for the Russian version of Outlook).
  • You create a message that contains some Russian characters, and then you save it as draft.
In this scenario, the body of the message is garbled after you send this draft.

↑ Back to the top


Cause

This issue occurs because the Exchange server does not update the character set in the PR_BODY_HTML property when the server changes the character set in the PR_INTERNET_CPID property. Therefore, the message body is garbled when Outlook tries to display it.

↑ Back to the top


Resolution

Configure the Outlook client to use UTF-8 for the Preferred encoding for outgoing messages option. To do this, follow these steps:
  1. In Outlook, select File>Option>Advanced.
  2. In the International options section, set the Preferred encoding for outgoing messages option to UTF-8.

↑ Back to the top


More Information

For more information about content conversion, see Content conversion.

For more information about the PidTagBodyHtml canonical property, see PidTagBodyHtml canonical property.

For more information about message-encoding options, see Message-encoding options.

↑ Back to the top


Keywords: kbsurveynew, kbtshoot, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 3140296
Revision : 1
Created on : 1/7/2017
Published on : 2/25/2016
Exists online : False
Views : 252