Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"DeviceId cannot contain hyphens" warning occurs when you use the Exchange Management Shell or the Exchange Administration Center to remove the associations in Exchange Server


View products that this article applies to.

Symptoms

You try to remove some Exchange ActiveSync device associations from Exchange Server 2013. When you use the Exchange Management Shell or the Exchange Administration Center to remove the associations, you receive following error message:

WARNING: An unexpected error has occurred and a Watson dump is being generated: DeviceId cannot contain hyphens.

In some cases, when you try to delete those device associations from the Active Directory database, you find that the device association is not included in the Active Directory database and cannot be removed at all.

↑ Back to the top


Cause

This problem occurs when a hyphen is used in the device identity. Additionally, the DistinguishedName field is changed if an Active Directory conflict exists.

↑ Back to the top


Resolution

To fix this problem, install Cumulative Update 12 for Exchange Server 2013 or a later cumulative update for Exchange Server 2013.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

Learn about the terminology that Microsoft uses to describe software updates.

↑ Back to the top


Keywords: kbqfe, kbsurveynew, kbnotautohotfix, kbfix, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 3137390
Revision : 1
Created on : 1/7/2017
Published on : 3/15/2016
Exists online : False
Views : 266