Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: Multiple Databases in a Single Storage Group Must Have Unique Names


View products that this article applies to.

This article was previously published under Q311441

↑ Back to the top


Symptoms

Exchange 2000 Enterprise Server enables a server to host up to five messaging databases in a single storage group. You may back up all of these databases to a file or backup media at the same time.

Patch files are created throughout an online backup of an Exchange 2000 Enterprise Server computer that runs Exchange 2000 Server Service Pack 1 (SP1) or earlier. These patch files contain data that the Exchange Server computer receives throughout the backup process. When the backup completes, these patch files are written to the backup file or to backup media.

In process of restoring of all the databases in the storage group, if these databases do not have unique names the following popup error will be shown when one of these databases is mounted:
An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both. ID no: c1041724 Exchange System Manager.
The following event ID messages may be logged in the Application event log:
Event Type: Error
Event Source: ESE98
Event Category: Logging/Recovery
Event ID: 430
Description:
Information Store (1484) Database and its patch file do not match.
Event Type: Error
Event Source: ESE98
Event Category: Logging/Recovery
Event ID: 454
Description:
Information Store (1484) Database recovery/restore failed with unexpected error -552.
-and-
Event Type: Information
Event Source: ESE98
Event Category: Logging/Recovery
Event ID: 205
Description:
Information Store (1484) The database engine has stopped restoring.

↑ Back to the top


Cause

This issue can occur because Exchange Server patch files automatically generate and use the same file name as the database that has a .pat file extension. When the restore process of an online backup completes, the patch files are written from backup media into a single folder on the hard disk that the user specifies. If the Exchange Server databases do not have unique names in the storage group, only one patch file is created on the hard disk, and then the patch file is overwritten. Because only one patch file is available to restore multiple databases, the restore process does not respond.

↑ Back to the top


Resolution

To resolve this issue:

  • Make sure that multiple Exchange Server databases in a storage group have unique names, even if they exist in separate folders on the hard disk.
    -or-
  • Upgrade to Exchange 2000 Server Service Pack 2 (SP2).
NOTE: After you upgrade to Exchange 2000 Server Service Pack 2 (SP2) from Exchange 2000 Server or Exchange 2000 Server Service Pack 1 (SP1), you may not be able to restore your earlier Exchange 2000 or Exchange 2000 SP1 backups to the Exchange 2000 SP2 server because, in Exchange 2000 SP2, the databases are upgraded to a newer version. For additional information about how to work around this behavior, click the article number below to view the article in the Microsoft Knowledge Base:
316794� Exchange 2000 SP2 Does Not Allow You to Restore Exchange 2000 or Exchange 2000 SP1

↑ Back to the top


Workaround

To work around this issue, restore only one Exchange Server database at a time.

↑ Back to the top


Keywords: KB311441, kbprb, kbpending

↑ Back to the top

Article Info
Article ID : 311441
Revision : 5
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 303