Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

ActiveSync device downloads emails while it's in quarantine in an Exchange Server 2013 environment


View products that this article applies to.

Symptoms

This issue occurs in a race condition, in which a Microsoft Exchange ActiveSync mobile device that's in quarantine can synchronize emails to the Inbox folder in a Microsoft Exchange Server 2013 environment.

Note This issue doesn't affect other folders in the mailbox. When the device sends a <Sync> command without a corresponding <Change> command, the SyncState element will no longer let email messages be downloaded.

↑ Back to the top


Cause

This issue occurs under the following conditions:
  • The ActiveSync mobile device is subject to quarantine.
  • The Allow/Block/Quarantine (ABQ) email messages that will be generally sent to the mailbox are deleted before the device synchronizes them.
  • The device sends a <Change> command on every synchronization request.
In this scenario, the <Change> command is allowed when the device is in quarantine, but it allows more than the bad ABQ emails to be downloaded.

↑ Back to the top


Workaround

To work around this issue, run the Remove-MobileDevice AffectedDeviceIdParameter cmdlet to remove the device from Exchange Server 2013 so that the SyncState element can be reset, and the device can resynchronize. This resolves the perpetual < Change> command.

↑ Back to the top


Resolution

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kb, kbqfe, kbexpertiseinter, kbfix, kbsurveynew

↑ Back to the top

Article Info
Article ID : 3105625
Revision : 2
Created on : 8/13/2020
Published on : 8/13/2020
Exists online : False
Views : 239