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PRB: BizTalk Server Database Setup Fails with CREATE DATABASE Failed Error


View products that this article applies to.

This article was previously published under Q309658

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Symptoms

The database setup portion in the BizTalk Server Setup program may fail and display the following error message:
An error occurred while attempting to create the BizTalk Messaging
Management database.  If the database already exists, try selecting 
it instead.

Hresult: 0x80040e14
Description: CREATE DATABASE failed.  Some file names listed could 
not be created.  Check previous errors. (2 error/s)
Source: Microsoft OLE DB Provider for SQL Server
					
After this error message displays, the following event may be logged in the Application log:
Event Type:	Warning
Event Source:	Application
Event Category:	None
Event ID:	         0
Date:		10/9/2001
Time:		10:39:08 AM
User:		N/A
Computer:	         BIZTALKSERVER
Description:
The description for Event ID ( 0 ) in Source ( Application ) cannot 
be found. The local computer may not have the necessary registry
information or message DLL files to display messages from a remote
computer. The following information is part of the event: An error 
occurred while attempting to create the BizTalk Messaging Management
database. If the database already exists, try selecting it instead.

Hresult: 0x80040e14
Description: CREATE DATABASE failed. Some file names listed 
could not be created. Check previous errors. (2 error/s)
Source: Microsoft OLE DB Provider for SQL Server.
					

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Cause

This error can occur if SQL Server attempts to create a new database with existing file names. By default, when SQL Server creates a new InterchangeBTM database, it creates the data and the InterchangeBTM.mdf and InterchangeBTM_log.ldf log files in the \Program Files\Microsoft SQL Server\MSSQL\Data folder.

If these files already exist in this folder, SQL Server cannot create the InterchangeBTM database, which in turn causes the database setup portion of the BizTalk Server Setup program to fail.

NOTE: The BizTalk Server database data and log files may exist in the SQL Server Data files directory if:
BizTalk Server has been previously installed, and then subsequently uninstalled. The BizTalk uninstall routine does not remove the BizTalk databases.

-or-

BizTalk Server has been previously installed, subsequently uninstalled, and the SQL Server installation that housed the BizTalk databases was uninstalled. The SQL Server uninstall routine does not remove any of the physical files used to create its databases.

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Resolution

Install the BizTalk Server databases with names that are different than the names of the files that already exist in the Program Files\Microsoft SQL Server\MSSQL\Data\ folder, or delete the files that exist in this folder if these file names match the names of the BizTalk databases that you are creating.

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Status

This behavior is by design.

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More information

Steps to Reproduce Behavior

  1. Stop the BizTalk Messaging Service for an existing installation of BizTalk Server.
  2. Detach the InterchangeBTM database for the existing BizTalk installation by right-clicking the InterchangeBTM database in the SQL Server Enterprise Manager, clicking All Tasks, and then clicking Detach Database. Click OK when you are prompted.
  3. Start the BizTalk Server Database Setup Wizard from the Program Files\Microsoft BizTalk Server\Setup\BTSSetupDB.exe file, and then click Next.
  4. In the Configure a BizTalk Messaging Management Database dialog box, click Create a new BizTalk Messaging Management database. Under the SQL Server connection parameters section, for Server name:, choose the SQL Server computer where your existing BizTalk Messaging Management database is located, enter the appropriate information for User name: and Password:, and then type InterchangeBTM for Database:.
  5. Click Next.

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Keywords: KB309658, kbprb

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Article Info
Article ID : 309658
Revision : 4
Created on : 10/17/2003
Published on : 10/17/2003
Exists online : False
Views : 255