Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error Message When You Attempt to Print a Web Page: An Error Has Occurred in the Script on This Page


View products that this article applies to.

Symptoms

In Microsoft Internet Explorer, when you attempt to print a Web page to a file, you may experience one of the following symptoms:
  • When you use the Print command on the File menu to print the Web page to a file, you receive an error message similar to the following:
    An error has occurred in the script on this page.

    Line: 1210
    Char: 1
    Error: Unspecified error.
    Code: 0
    URL: res://C:\WINDOWS\SYSTEM\SHDOCLC.DLL/preview.dlg

    Do you want to continue running scripts on this page?
  • When you use the Print Preview command on the File menu, and then print the Web page to a file from within the Print Preview window, you receive the following error message:
    There was an internal error, and Internet Explorer is unable to print this document.
In each case, the document is printed correctly.

↑ Back to the top


Cause

This behavior occurs if both of the following conditions are true:
  • You use a PostScript printer driver.
  • You select Encapsulated PostScript (EPS) output in the printer name Properties dialog box, where printer name is the name of your PostScript printer.
This behavior can also occur if you configure your printer to add a header and footer to each page that you print.

↑ Back to the top


Resolution

To resolve this issue, use the appropriate method.

Postscript Printer Driver

Clear the Encapsulated PostScript (EPS) output selection in the printer name Properties dialog box.

Remove Header and Footer from Printer Properties

Use the Printers tool in Control panel to remove or disable any automatic headers and footers. For information about how to do this, please see the printed documentation or online Help file for your printer.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: KB303486, kbpending, kberrmsg, kbbug

↑ Back to the top

Article Info
Article ID : 303486
Revision : 7
Created on : 5/7/2007
Published on : 5/7/2007
Exists online : False
Views : 565