Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Third-party transport agents cannot be loaded correctly in Exchange Server 2013


View products that this article applies to.

Symptoms

After you install Microsoft Exchange Server 2013 Service Pack 1 (SP1) or you upgrade an existing Microsoft Exchange Server 2013 installation to Exchange Server 2013 SP1, third-party or custom-developed transport agents cannot be installed correctly. Additionally, the Microsoft Exchange Transport service (MSExchangeTransport.exe) cannot start automatically. Specifically, you cannot enable third-party products that rely on transport agents. For example, you cannot enable anti-malware software or custom-developed transport agents.

When the installation fails, you also receive an error message that resembles the following:

The TransportAgentFactory type must be the Microsoft .NET class type of the transport agent factory.

↑ Back to the top


Cause

This problem occurs because the global assembly cache (GAC) policy configuration files contain invalid XML code.

↑ Back to the top


Resolution

Microsoft has developed a PowerShell script that corrects a formatting error in the configuration files that govern the Transport Extensibility that is built into Exchange Server 2013. To have us apply this script for you so that Transport Extensibility and third-party products that use this capability function correctly, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.



Fix it for me

To fix this problem automatically on a server that experiences the symptoms that are mentioned in the “Symptoms” section, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.

Note This script applies only to servers that are running Exchange Server 2013 SP1. A permanent fix for this solution will be delivered in Exchange Server 2013 Cumulative Update 5 (CU5).




Let me fix it myself

To obtain and run the script manually, go to the following Microsoft Download Center website:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

If you upgrade an existing Exchange Server 2013 installation that has third-party agents installed to Exchange Server 2013 SP1, you can restore the server to its regular operation by running the script in the "Fix it" solution.

However, if you install Exchange Server 2013 SP1 on a new server, and then you install third-party agents before you run apply "Fix it" solution, you must follow these steps to restore the server:
  1. Uninstall the third-party agents.
  2. Run the script.
  3. Reinstall the agents.
To avoid these steps, make sure that you apply the "Fix it" solution to any server that is running Exchange Server 2013 SP1 immediately after the installation. Then, you can install any third-party agents.

For more information about Exchange Server 2013 SP1, go to the following Microsoft website:
2926248 Description of Exchange Server 2013 Service Pack 1

↑ Back to the top


Keywords: kb, kbexpertiseadvanced, kbsurveynew, kbfix, kbqfe

↑ Back to the top

Article Info
Article ID : 2938053
Revision : 2
Created on : 4/9/2020
Published on : 4/9/2020
Exists online : False
Views : 494