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DBCS characters appear garbled when you run some PowerShell scripts in EMS in an Exchange Server 2013 environment


View products that this article applies to.

Symptoms

Assume that Microsoft Exchange Server 2013 is installed on a computer that is configured to use a display language that uses Double-Byte Character Set (DBCS) characters, such as Japanese. Then, you run one of the following scripts in Exchange Management Shell (EMS):
  • Disable-AntimalwareScanning.ps1
  • Enable-AntimalwareScanning.ps1
  • FilterringConfigurationCommands.ps1
  • StoreTSLibrary.ps1
  • Update-MalwareFilteringServer.ps1
In this situation, the DBCS characters appear garbled. More specifically, the characters resemble the following:
�}���E�F�A�΍�G���W����X�V���ł��B����ɂ͐���������܂��B
DateTime ��ɍX�V���ꂽ�G���W����m�F���Ă��܂��B
Microsoft ��X�V���Ă��܂��B�ŏI�X�V: 1900/01/01 9:00:00

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Cause

This issue occurs because the *.strings.psd1 files that correspond to the scripts use the American National Standards Institute (ANSI) format instead of the 16-bit Unicode Transformation Format (UTF-16).

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Resolution

To resolve this issue, install the following cumulative update: 
2892464 Description of Cumulative Update 3 for Exchange Server 2013

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Workaround

To work around this issue, save the *.strings.psd1 files in the UTF-16 format in the language specific subfolders in the Scripts folder.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about the ANSI format and the Unicode format, go to the following Microsoft website:

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

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Article Info
Article ID : 2895500
Revision : 1
Created on : 1/7/2017
Published on : 11/25/2013
Exists online : False
Views : 362