Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a "Device not ready" error message when you try to restore a database to a different file path in Exchange 2000 Server


View products that this article applies to.

This article was previously published under Q288558

↑ Back to the top


Symptoms

If you try to restore a database to a different file path in a scenario where the log files did not have a clean shutdown, you may receive the following error message:
The device is not ready.
JET_errDiskIO
For example, you may receive this error message if the original database file path was D:\pub.edb, and the new server references drive D as a CD drive.

↑ Back to the top


Cause

This problem occurs because, when the log files do not have a clean shutdown, JET (ESE98) tries to build a full restore path based from the database and ignores the prompt that it is restoring to another destination. JET cannot continue after it receives the error that the destination is unavailable, such as a message that the CD drive is not ready.

↑ Back to the top


Resolution

To resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378� XGEN: How to obtain the latest Exchange 2000 Server service pack

↑ Back to the top


Workaround

To work around this problem, put a CD in the CD drive. This action makes the CD drive ready, and JET (ESE98) can then continue and can complete the restore successfully.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.

↑ Back to the top


Keywords: KB288558, kbpending, kbexchange2000presp1fix, kbbug, kberrmsg

↑ Back to the top

Article Info
Article ID : 288558
Revision : 4
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 440