Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"The Office program has entered or may enter Reduced Functionality Mode (RFM)" warning when you open an Office Professional Plus program


View products that this article applies to.

Problem

When you open a Microsoft Office Professional Plus program, you receive the following warning message:
The Office program has entered or may enter Reduced Functionality Mode (RFM).

↑ Back to the top


Cause

This issue occurs when one or more of the following conditions are true:
  • Internet connectivity is lost.
  • The computer has not checked into Office Subscription in the last 30 days.
  • The computer is not provisioned or was removed from the subscription account.
  • The user was previously deprovisioned.
  • The system clock differs from the Office Subscription Service clock.
In these cases, you cannot verify Office Subscription licensing.

↑ Back to the top


Solution

To resolve this issue, follow these steps:
  1. Enable application logging. To do this, follow these steps:
    1. Enable verbose logging before you collect the log files.
    2. Click Start, and then click All Programs.
    3. Click Accessories, and then click Run.
    4. Type reg add HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Debug /v TCOTrace /t REG_DWORD /d 1.
    5. Click OK.
  2. Start the application to reproduce the error.
  3. Review the error log that is located in the Temp folder. To find the Temp folder, follow these steps:
    1. Click Start, and then click All Programs.
    2. Click Accessories, and then click Run.
    3. Type %temp%, and then click OK.

    The following log files may be present in the Temp folder:
    • Bootstrapper*.log
    • c2r_*.log
    • C2RIntegrator*.log
    • Firefly*.log
    • Integratedoffice.exe_c2r*.log
    • Interceptor*.log
    • *.exe.log
    • *_c2rdll*
    Note "c2r" is for Click-to-Run.

    The log file to look for is named after the application that you use to reproduce the error. For example, if you use Microsoft Word to reproduce the error, you should look for the "winword.exe.log" file. You can select the appropriate log file from the following file names:�
    • winword.exe.log
    • excel.exe.log
    • lync.exe.log
    • onenote.exe.log
    • powerpnt.exe.log
    • visio.exe.log
    • access.exe.log
    • publisher.exe.log
    • outlook.exe.log
    • project.exe.log
    • winproj.exe.log

  4. After you locate the Application log file, perform a Find for connectivity check failed, returning ErrorNoConnectivity. For example, the log output resembles the following:
    2013/04/26 13:18:23:363::[4236] AuthLiblet already initialized in this process
    2013/04/26 13:18:23:457::[4236] CredStore::InitInstance succeeded
    2013/04/26 13:18:23:551::[4236] CredStore::InitInstanceFrom replacing current s_pocs
    2013/04/26 13:18:24:723::[2100] ServiceAPI: ServiceStatus: checking permissions... success
    2013/04/26 13:18:24:739::[2100] ServiceAPI: ServiceStatus: checking connectivity...
    2013/04/26 13:18:24:739::[2100] ServiceAPI: ServiceStatus: connectivity check failed, returning ErrorNoConnectivity
    2013/04/26 13:18:24:739::[2100] OfficeServicesManager::ServicesCacheHelper::HandleConnectedServices() Web Connectivity is not available
    2013/04/26 13:18:24:739::[2100] OfficeServicesManager::ServicesCacheHelper::HandleConnectedServices() EXPIRED
    2013/04/26 13:18:24:739::[2100] OfficeServicesManager::ServicesCacheHelper::HandleConnectedServices() PARTIAL
  5. Verify server connectivity.

    Office 365 ProPlus requires Internet connectivity to the Office Subscription Service (OSS) to keep Office open and fully functional. To verify that you can connect, open a browser, and then try to access the following webpage:
    If you still receive an "Internet connection required" error message when you start Office 365 ProPlus even though you can access the link, follow the steps at the following Microsoft TechNet website:
  6. Disable application logging. To do this, follow these steps:
    1. Enable verbose logging before you collect the log files.
    2. Click Start, and then click All Programs.
    3. Click Accessories, and then click Run.
    4. Type reg add HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Debug /v TCOTrace /t REG_DWORD /d 0.
    5. Click OK.


↑ Back to the top


More information

Verify that the computer can access the Internet. If the error persists after you perform all the steps, Office Subscription is unavailable. In this case, you should wait and try again later.

↑ Back to the top


Still need help? Go to the Office 365 Community website.

↑ Back to the top


Keywords: KB2826877, upgrade, after, o365m, o365p, o365e, o365, o365022013

↑ Back to the top

Article Info
Article ID : 2826877
Revision : 3
Created on : 5/31/2013
Published on : 5/31/2013
Exists online : False
Views : 744