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An application that calls the CloseHandle function on a serial port cannot be exited in Windows Vista, Windows 7, Windows Server 2008, or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Assume that you have an application that uses the serial ports in Windows Vista, Windows 7, Windows Server 2008, or Windows Server 2008 R2. In this scenario, when the application calls the CloseHandle function on a serial port, the function does not return, and the application cannot be exited. To temporarily resolve this issue, you have to restart the computer.

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Cause

This problem may occur because the Serial.sys file is stuck in an infinite loop after the CloseHandle function is called.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have one of the following installed to apply this hotfix:
  • Windows 7 Service Pack 1
  • Windows Server 2008 R2 Service Pack 1
  • Windows Vista Service Pack 2
  • Windows Server 2008 Service Pack 2
See Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R for more information.

See How to obtain the latest Windows Vista service pack for more information.

See How to obtain the latest service pack for Windows Server 2008 for more information.

Restart information

You must restart the computer after you apply this hotfix.

Replacement information

This hotfix does not replace any previously released hotfix.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.1.7601.22xxxWindows 7 and Windows Server 2008 R2SP1LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Serial.sys6.1.7601.2230783,96822-Apr-201303:10x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Serial.sys6.1.7601.2230794,20822-Apr-201303:44x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Serial.sys6.1.7601.22307195,07222-Apr-201303:16IA-64
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.0.6002.23xxxWindows Vista SP2 and Windows Server 2008 SP2SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Serial.sys6.0.6002.2310083,96823-Apr-201302:29x86
Wacompen.sys6.0.6002.2310020,60823-Apr-201302:30Not Applicable
Parport.sys6.0.6002.2310079,36023-Apr-201302:29x86
Parvdm.sys6.0.6002.231008,70423-Apr-201302:29x86
Serenum.sys6.0.6002.2310017,92023-Apr-201302:29x86
Serial.sys6.0.6002.2310083,96823-Apr-201302:29x86
For all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Serial.sys6.0.6002.2310094,20823-Apr-201302:21x64
Wacompen.sys6.0.6002.2310026,62423-Apr-201302:22x64
Parport.sys6.0.6002.2310096,76823-Apr-201302:21x64
Serenum.sys6.0.6002.2310023,55223-Apr-201302:20x64
Serial.sys6.0.6002.2310094,20823-Apr-201302:21x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Serenum.sys6.0.6002.2310052,73623-Apr-201301:20IA-64
Serial.sys6.0.6002.23100195,07223-Apr-201301:20IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_msports.inf_31bf3856ad364e35_6.1.7601.22307_none_fb366bb82fb34f48.manifest
File versionNot Applicable
File size3,506
Date (UTC)22-Apr-2013
Time (UTC)11:19
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_msports.inf_31bf3856ad364e35_6.1.7601.22307_none_5755073be810c07e.manifest
File versionNot Applicable
File size2,988
Date (UTC)22-Apr-2013
Time (UTC)11:22
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_msports.inf_31bf3856ad364e35_6.1.7601.22307_none_fb380fae2fb15844.manifest
File versionNot Applicable
File size2,462
Date (UTC)22-Apr-2013
Time (UTC)11:16
PlatformNot Applicable

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_hiddigi.inf_31bf3856ad364e35_6.0.6002.23100_none_97cc422e5c1ffc6b.manifest
File versionNot Applicable
File size2,254
Date (UTC)23-Apr-2013
Time (UTC)09:01
PlatformNot Applicable
File nameX86_msports.inf_31bf3856ad364e35_6.0.6002.23100_none_fb07ae4ecea24a37.manifest
File versionNot Applicable
File size3,410
Date (UTC)23-Apr-2013
Time (UTC)09:01
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_hiddigi.inf_31bf3856ad364e35_6.0.6002.23100_none_f3eaddb2147d6da1.manifest
File versionNot Applicable
File size2,256
Date (UTC)23-Apr-2013
Time (UTC)09:01
PlatformNot Applicable
File nameAmd64_msports.inf_31bf3856ad364e35_6.0.6002.23100_none_572649d286ffbb6d.manifest
File versionNot Applicable
File size2,834
Date (UTC)23-Apr-2013
Time (UTC)09:01
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_msports.inf_31bf3856ad364e35_6.0.6002.23100_none_fb095244cea05333.manifest
File versionNot Applicable
File size2,253
Date (UTC)23-Apr-2013
Time (UTC)09:01
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2809097
Revision : 1
Created on : 1/7/2017
Published on : 6/12/2013
Exists online : False
Views : 203