Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Marketplace web services are currently unavailable" error message when you install an app from Marketplace by using Outlook or Outlook Web App in an Exchange Server 2013 environment


View products that this article applies to.

Symptoms

Assume that the Exchange server roles in a Microsoft Exchange Server 2013 environment access the Internet through a proxy. In this situation, the following issues occur:
  • When a user tries to install an app in Outlook or in Outlook Web App , the user receives the following error message:
    The app couldn't be downloaded.
    Error message: Marketplace web services are currently unavailable. Please try again in a few minutes.
  • When the administrator tries to run the New-App cmdlet in Exchange Management Shell to install an app, the installation process fails. For example, the administrator runs the following cmdlet in Exchange Management Shell:
    New-App -MarketplaceQueryMarket en-us -MarketplaceAssetID WA102996382 -MarketplaceServicesUrl "https://o15.officeredir.microsoft.com/config15"
    In this example, the installation process fails, and the administrator receives the following error message:
    The app couldn't be downloaded. Error message: Marketplace web services are currently unavailable. Please try again in a few minutes.
Note The issue occurs even when the WinHTTP proxy is configured on Exchange servers and when the marketplace URL can be accessed from the Exchange server by using a web browser.

↑ Back to the top


Cause

This issue occurs because the account on the computer that Powershell or Exchange Control Panel (ECP) runs on does not use the WinHTTP proxy or the browser proxy.

↑ Back to the top


Resolution

To resolve this issue, run the following command to configure the proxy for the accounts on the computer:
bitsadmin /Util /setIEProxy localsystem MANUAL_PROXY Proxy address "exceptions"
For example, run the following command:
bitsadmin /Util /setIEProxy localsystem MANUAL_PROXY ISAPROXY "*.contoso.com;<local>"

↑ Back to the top


More Information

For more information about the New-App cmdlet, go to the following Microsoft website:For more information about the Bitsadmin /util command, go to the following Microsoft website:

↑ Back to the top


Keywords: kbtshoot, kbsurveynew, kbexpertiseadvanced, kbprb, kb

↑ Back to the top

Article Info
Article ID : 2807325
Revision : 1
Created on : 1/7/2017
Published on : 2/8/2013
Exists online : False
Views : 476