Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

How to search for deleted items in an Exchange mailbox


View products that this article applies to.

Symptoms

Email messages or other Microsoft Outlook items in a Microsoft Exchange Server mailbox are not available.

↑ Back to the top


Cause

This issue occurs because deleted items are stored in several mailbox locations before those items are completely removed.

↑ Back to the top


Resolution

Note�This article describes a range of resolutions. This range includes tasks with which a user is familiar and also actions that have to be completed by a support engineer. For more information about recoverable items in Exchange Server 2010, go to the following Microsoft TechNet website:
An Exchange mailbox contains three folders that store deleted items:
  • Deleted Items
  • Deletions
  • Purges




Two of these folders exist in the mailbox dumpster and are not on the mailbox folder list. All three folders are described in detail in the following sections.

Note�Email folders, subfolders or structures are not recoverable. Only the contents of email folders that are missing or deleted can be restored.

Deleted Items folder

The Deleted Items folder is a default folder that is available in the folder list of an Exchange mailbox.��

When you take one of the following actions,�an item is moved to the Deleted Items folder in Outlook:
  • You press the Delete button on the keyboard when an item is highlighted.
  • You right-click an item when the item is highlighted and then select Delete.
  • You accept or delete meeting invitations from the Inbox folder. (Meeting invitations are automatically moved to the Deleted Items folder after they are accepted or deleted.)

Deletions folder

The Deletions folder is in the mailbox dumpster. You can access the Deletions folder from Outlook. For more information about how to access the Deletions folder in different versions of Outlook, go to one of the following Microsoft websites:�When you take one of the following actions, an item is moved to the Deletions folder:

Purges folder

If an item is manually removed from the Deletions folder, the item is moved to the Purges folder. The item remains in the Purges folder until the 30-day dumpster-retention period is completed.�

You cannot access the Purges folder through Outlook. You can access the Purges folder by using Microsoft Exchange Server MAPI Editor (MFCMAPI). To do this, follow these steps:

Note By default, MAPI access is blocked for deskless-worker (Exchange Online Kiosk) mailboxes. To follow the steps in the following list, the MAPI block must be temporarily removed. Members of the Protocol Control self-service group can use Windows Remote PowerShell to temporarily enable MAPI for deskless-worker mailboxes.


To remove the MAPI block, run the following cmdlet in Windows Remote PowerShell:
Set-CASMailbox <UserIdentity> -MAPIBlockOutlookVersions $NULL
To restore the MAPI block, run the following cmdlet in Windows Remote PowerShell:
Set-CASMailbox <UserIdentity> -MAPIBlockOutlookVersions 0.0.0-100.0.0

Note�The following procedure requires the user to have full access to the mailbox and to a profile that is configured in online mode.�
  1. Download MFCMAPI from the following CodePlex website:�
    Note�You will have�the option of downloading the 32-bit or 64-bit executable file. You should download the version that corresponds to the version of Outlook that is installed on your computer.
  2. Double-click the executable file to start MFCMAPI.
  3. When you are prompted with the information screen, click OK.�
  4. On the Session menu, click Logon.

  5. Select the appropriate online profile for the mailbox that is to be accessed, or click New.


  6. Double-click the first entry in the top section of the screen. The user's mailbox will open.


  7. Expand Root Container, and then expand Recoverable Items. You will see three subfolders: Deletions, Purges, and Versions.



    Notes
    • The Versions folder contains the original copies of items that were changed. Recovering items from this folder will help if a user wants access to an earlier copy of a changed appointment or contact. You should never restore all contents from the Versions folder to a user's active calendar. These items are usually referenced for troubleshooting only.�
    • The Audit folder exists if mailbox auditing is enabled for the mailbox.
  8. Double-click the Purges folder. A new window opens. In this window, the top section lists all the items in the folder. The bottom section contains the properties that are associated with the message.�


  9. Click any of the columns to sort in ascending or descending order. If you find the message that you want to recover, you can take one of the following actions for one or multiple messages:�
    • Export the message to a file. To do this, right-click the item, and then select Export message.


    • Copy and paste the item. To do this, , follow these steps:
      1. Right-click the item and then select�Copy Message.
      2. Right-click the folder into which you want to paste the item, and then select Paste.�You are given the option to move the message instead.



    If you want just one version of the item in the destination folder, click to select the MESSAGE_MOVE check box, and then click OK.

    Note The mailbox folder list is under Top of Information Store.





↑ Back to the top


Keywords: vkbportal226, kbgraphxlink, KB2786067

↑ Back to the top

Article Info
Article ID : 2786067
Revision : 4
Created on : 7/11/2013
Published on : 7/11/2013
Exists online : False
Views : 1001