Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Cannot access Outlook on the Web or the EAC after you re-create the "owa" or "ECP" virtual directory on an Exchange Server Mailbox server


View products that this article applies to.

Symptoms

Assume that you use the New-OWAVirtualDirectory or New-ECPVirtualdirectory cmdlet to re-create the "owa" or "ECP" virtual directory on a Microsoft Exchange Server 2013 or Microsoft Exchange Server 2016 Mailbox server. In this situation, when users try to access Outlook Web App, Outlook on the Web, or the Exchange Administration Center (EAC), they receive an "Http 404" error code. 

↑ Back to the top


Cause

This issue occurs because an incorrect authentication method is set for the "owa" and "ECP" virtual directories. When you run the New-OWAVirtualDirectory or New-ECPVirtualdirectory cmdlet to create the "owa" or "ECP" virtual directory, the cmdlet incorrectly enables Forms authentication and Basic authentication instead of Windows authentication.

↑ Back to the top


Workaround

To work around this issue, follow these steps.

For the "owa" virtual directory

  1. Open Exchange Management Shell (EMS), and then run the following cmdlet to change the authentication method of the "owa" virtual directory to Windows authentication:
    set-Owavirtualdirectory -identity "E15MBX\owa (Exchange Back End)" -WindowsAuthentication $True -Basicauthentication $false -Formsauthentication $false
  2. Run the following command on both the Client Access and Mailbox servers to restart Internet Information Services (IIS):
    iisreset /noforce

For the "ECP" virtual directory

  1. Start Windows PowerShell.
  2. Type the following commands, and then press Enter after each line:
    Add-PSSnapin *exchange*

    Set-EcpVirtualDirectory -Identity "E15MBX\ecp (Exchange Back End)" -WindowsAuthentication $true -FormsAuthentication $false
  3. Run the following command on both the Client Access and Mailbox servers to restart Internet Information Services (IIS):
    iisreset /noforce

↑ Back to the top


Keywords: kbsurveynew, kbtshoot, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2778897
Revision : 1
Created on : 1/7/2017
Published on : 11/29/2017
Exists online : False
Views : 381