Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Adding a large application package via the Management Server console on App-V v5 fails with "Timeout expired"


View products that this article applies to.

Symptoms

In Microsoft Application Virtualization (App-V) v5, adding a large application package (e.g., Visual Studio 2010) using the Management Server console fails with the following error:

There were problems interacting with the database on the server. The error was: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

↑ Back to the top


Cause

This issue occurs because the package import operation exceeded the database timeout period.

↑ Back to the top


Resolution

To resolve this issue, increase the DatabaseCommandTimeout value by performing the following steps:

1. Navigate to the following directory:

%systemdrive%\Program Files\Microsoft Application Virtualization Server\ManagementService
2. Open the Web.config file using Notepad and increase the following value:

<add key="DatabaseCommandTimeout" value="30"/> <!-- in second, 30 is system default value -->
3. Attempt to add the package again using the Management Server. If the import operation fails, continue to increase the DatabaseCommandTimeout value until the operation succeeds.

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2778019
Revision : 2
Created on : 3/27/2020
Published on : 3/27/2020
Exists online : False
Views : 432