Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A process that is being terminated crashes in Windows Vista or in Windows Server 2008


View products that this article applies to.

Symptoms

Assume that you attempt to terminate a process on a computer that is running Windows Vista or Windows Server 2008. In this situation, the process that is being terminated freezes. When this issue occurs, the main thread of the process becomes blocked, and the process does not terminate.

If you analyze the call stack of the process when this issue occurs, you notice that a thread is blocked in the ntdll!NtReleaseKeyedEvent() function.

↑ Back to the top


Cause

This issue occurs because the main thread that terminates the process tries to reactivate another thread that was terminated when the thread released an SRW lock. This race condition causes the process to crashes.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 SP2.

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Vista and for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTime
Ntdll.dll6.0.6002.229261,205,57605-Sep-201216:53
For all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Ntdll.dll6.0.6002.229261,585,68805-Sep-201216:50x64
Ntdll.dll6.0.6002.229261,168,49605-Sep-201216:50x86
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Ntdll.dll6.0.6002.229262,569,60805-Sep-201216:43IA-64
Ntdll.dll6.0.6002.229261,168,49605-Sep-201216:43x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about a process that stops responding, click the following article number to view the article in the Microsoft Knowledge Base:
2582203 A process that is being terminated stops responding in Windows 7 or in Windows Server 2008 R2
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_6ca6f5b19421ded20220157000b24ef5_31bf3856ad364e35_6.0.6002.22926_none_a83d3659927e9730.manifest
File versionNot applicable
File size717
Date (UTC)05-Sep-2012
Time (UTC)16:54
File nameX86_fe776bc530e719e76081ec11be93e6ea_31bf3856ad364e35_6.0.6002.22926_none_5fd48fab255683df.manifest
File versionNot applicable
File size693
Date (UTC)05-Sep-2012
Time (UTC)16:54
File nameX86_microsoft-windows-ntdll_31bf3856ad364e35_6.0.6002.22926_none_5b3763bb127c519d.manifest
File versionNot applicable
File size5,257
Date (UTC)05-Sep-2012
Time (UTC)16:54
File nameX86_microsoft-windows-r..gistry-trustedtypes_31bf3856ad364e35_6.0.6002.22926_none_865e7f0c44b6c289.manifest
File versionNot applicable
File size7,654
Date (UTC)05-Sep-2012
Time (UTC)14:49
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_429f2e946fe8e291240965bfd4441c4f_31bf3856ad364e35_6.0.6002.22926_none_47f16baf21215ad9.manifest
File versionNot applicable
File size721
Date (UTC)05-Sep-2012
Time (UTC)16:54
File nameAmd64_caf5018d596aa8d4c5d045886ab05717_31bf3856ad364e35_6.0.6002.22926_none_e469f1f8f2eeb9a2.manifest
File versionNot applicable
File size1,036
Date (UTC)05-Sep-2012
Time (UTC)16:54
File nameAmd64_microsoft-windows-ntdll_31bf3856ad364e35_6.0.6002.22926_none_b755ff3ecad9c2d3.manifest
File versionNot applicable
File size5,263
Date (UTC)05-Sep-2012
Time (UTC)16:54
File nameAmd64_microsoft-windows-r..gistry-trustedtypes_31bf3856ad364e35_6.0.6002.22926_none_e27d1a8ffd1433bf.manifest
File versionNot applicable
File size7,656
Date (UTC)05-Sep-2012
Time (UTC)15:55
File nameWow64_microsoft-windows-ntdll_31bf3856ad364e35_6.0.6002.22926_none_c1aaa990ff3a84ce.manifest
File versionNot applicable
File size5,829
Date (UTC)05-Sep-2012
Time (UTC)16:54
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_3c922656aee973a506505241b6316bcd_31bf3856ad364e35_6.0.6002.22926_none_ab2b39b1d37d082e.manifest
File versionNot applicable
File size719
Date (UTC)05-Sep-2012
Time (UTC)16:54
File nameIa64_dd4a88a2942f61691470b8da14f4dc95_31bf3856ad364e35_6.0.6002.22926_none_8f78679e68505372.manifest
File versionNot applicable
File size1,034
Date (UTC)05-Sep-2012
Time (UTC)16:54
File nameIa64_microsoft-windows-ntdll_31bf3856ad364e35_6.0.6002.22926_none_5b3907b1127a5a99.manifest
File versionNot applicable
File size5,260
Date (UTC)05-Sep-2012
Time (UTC)16:54
File nameIa64_microsoft-windows-r..gistry-trustedtypes_31bf3856ad364e35_6.0.6002.22926_none_8660230244b4cb85.manifest
File versionNot applicable
File size7,655
Date (UTC)05-Sep-2012
Time (UTC)14:23
File nameWow64_microsoft-windows-ntdll_31bf3856ad364e35_6.0.6002.22926_none_c1aaa990ff3a84ce.manifest
File versionNot applicable
File size5,829
Date (UTC)05-Sep-2012
Time (UTC)16:54

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2752711
Revision : 1
Created on : 1/7/2017
Published on : 10/10/2012
Exists online : False
Views : 264