Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: MTS or IIS with ODBC Connection Pooling May Hang If Database Becomes Unavailable


View products that this article applies to.

This article was previously published under Q274569

↑ Back to the top


Symptoms

When ODBC connection pooling is enabled, if database servers are down or unavailable due to network connectivity issues, Internet Information Server (IIS) or Microsoft Transaction Server (MTS) may stop responding (hang).

↑ Back to the top


Cause

This behavior is caused by a bug in the resource dispenser (Mtxdm.dll). The threads that perform connection pooling wait for the ODBC thread that is trying to perform an ODBC call, which results in a deadlock condition.

↑ Back to the top


Resolution

The resource dispenser has been modified to resolve this problem. To obtain the corrected version of Mtxdm.dll, install Microsoft Data Access Components (MDAC) version 2.5 or later from the following Microsoft Web Site: You can also obtain this fix by installing Microsoft Windows NT 4.0 Service Pack 6a or later. For more information, see the following Web site:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem has been corrected in MDAC version 2.5 and later, and in Windows NT 4.0 Service Pack 6a and later.

↑ Back to the top


Keywords: KB274569, kbqfe, kbfix, kbbug

↑ Back to the top

Article Info
Article ID : 274569
Revision : 5
Created on : 11/18/2003
Published on : 11/18/2003
Exists online : False
Views : 349