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Error message when you test the adapter settings when installing the CRM Connector for Microsoft Dynamics SL


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Symptoms

When you install the CRM Connector for Microsoft Dynamics SL you may receive the following message when you click Test Settings in the Settings for Adapters screen.

Test settings failed:

The message with Action 'GetCompanyIDs' cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This
may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding including security requirements. For example, Message, Transport, None.



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Cause

This problem occurs because Dynamics SL 2011 Service Pack 1 (SP1) has not been applied to the Dynamics SL Web Services installation on the Web Server.

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Resolution

Apply Dynamics SL 2011 Service Pack 1 to the Dynamics SL Web Services installation  the Web Server.

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Keywords: kbmbsmigrate, kbmbspartner, kbsurveynew, kb

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Article Info
Article ID : 2743759
Revision : 2
Created on : 2/3/2017
Published on : 2/3/2017
Exists online : False
Views : 302