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Error message when you run "wbadmin start systemstatebackup" to back up the system state of a Windows Vista-based or Windows Server 2008-based virtual machine that is running on a VMware host server


View products that this article applies to.

Symptoms

Assume that you have a Windows Vista-based or Windows Server 2008-based virtual machine that is running on a VMware host server. You try to back up the system state of the virtual machine by running the following command:
wbadmin start systemstatebackup -backupTarget: volume name -quiet
In this scenario, the backup operation randomly fails. Additionally, the following event is logged in the Application log:Additionally, you receive an error message that resembles the following:
There was a failure in preparing the backup image of one of the volumes in the backup set. Failed to format media.

When this issue occurs, the following message that relates to the failed format operation of the virtual hard disk (VHD) is logged in the WBDiag trace log:
INFO:IoCreateDeviceSecure successful. VolumeDevice FFFFFA800287F8C0, Type: 7l, VolumeName: \Device\HarddiskVolumeFile199
INFO:Volume \\?\GLOBALROOT\Device\HarddiskVolumeFile199 created for backupfile \\?\Volume{5ce7b92d-9a0f-11df-8e85-806e6f6e6963}\WindowsImageBackup\nvhb01v\SystemStateBackup\Backup\5ce7b92a-9a0f-11df-8e85-806e6f6e6963.vhd
:
INFO:CreateFile for \\?\GLOBALROOT\Device\HarddiskVolumeFile199 succeeded after 0 secs.
:
VERBOSE:Format is for DVD? NO, Volume to format \\?\GLOBALROOT\Device\HarddiskVolumeFile199
INFO:Media label to be set - VHD
ERROR:Format was unable to complete successfully, final result: 57 <------
ERROR:Format on \\?\GLOBALROOT\Device\HarddiskVolumeFile199 failed.
INFO:Format done
ERROR:FormatMedia \\?\GLOBALROOT\Device\HarddiskVolumeFile199 failed, hr: 0x80780046
:
ERROR:Error 0x807800c5

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Cause

This issue occurs because the computer starts to back up the system state before the VHD is mounted. When you start to back up the system state, the computer checks whether the corresponding VHD is mounted and surfaced correctly, and then the computer starts to format the VHD. However, because of a timing window issue, the check is passed before the VHD is mounted. Therefore, the system state backup operation fails.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 SP2.

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Vista and for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Wbengine.exe6.0.6002.22910919,55208-Aug-201213:11x86
For all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Wbengine.exe6.0.6002.229101,149,95208-Aug-201213:48x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Wbengine.exe6.0.6002.229102,823,68008-Aug-201212:51IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

Note: The issue described in the Symptoms section is not limited to virtual machines running on VMware host or Hyper-V host. The issue can also occur on a Physical machine that is running  Windows Vista-based or Windows Server 2008-based operating system.

For more information about the wbadmin start systemstatebackup command, go to the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_d2ebcf8475ae8f81f9cec782dc0e4712_31bf3856ad364e35_6.0.6002.22910_none_08d01f113d42e661.manifest
File versionNot applicable
File size703
Date (UTC)23-Aug-2012
Time (UTC)05:59
PlatformNot applicable
File nameX86_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6002.22910_none_e64749a1160bda65.manifest
File versionNot applicable
File size12,539
Date (UTC)08-Aug-2012
Time (UTC)14:58
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_edd3038a702e0877b1af7e2e414e4cea_31bf3856ad364e35_6.0.6002.22910_none_f957b3a02b8422e1.manifest
File versionNot applicable
File size707
Date (UTC)23-Aug-2012
Time (UTC)05:59
PlatformNot applicable
File nameAmd64_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6002.22910_none_4265e524ce694b9b.manifest
File versionNot applicable
File size12,571
Date (UTC)08-Aug-2012
Time (UTC)15:46
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_e693e763611db91e526fdb096179667b_31bf3856ad364e35_6.0.6002.22910_none_948341c9343caaec.manifest
File versionNot applicable
File size705
Date (UTC)23-Aug-2012
Time (UTC)05:59
PlatformNot applicable
File nameIa64_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6002.22910_none_e648ed971609e361.manifest
File versionNot applicable
File size12,555
Date (UTC)08-Aug-2012
Time (UTC)14:34
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2727978
Revision : 2
Created on : 9/20/2018
Published on : 9/21/2018
Exists online : False
Views : 278