Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

ROI.EXE has stopped working error message in Microsoft Dynamics SL


View products that this article applies to.

Symptoms

When you try to print any report in Microsoft Dynamics SL 2011, you receive the following error:

ROI.EXE has stopped working


↑ Back to the top


Cause

The RI_ID value in the RPTRUNTIME table has exceeded the limit of 32,767.

↑ Back to the top


Resolution

Clear the records in the RPTRUNTIME table to reset the RI_ID value back to 1.  To do this, follow these steps:

  1. Verify that all users have logged out of Microsoft Dynamics SL
  2. Start Microsoft SQL Server Management Studio
  3. Run the following statement against the SL System database and the SL Application database(s)
    delete from rptruntime

↑ Back to the top


More Information

The RPTRUNTIME table contains temporary information that relates to an active print process. Typically this table is empty when there are no users running a report. Ocassionally a record may be stranded in this table which can increase the chances of maxing out the RI_ID values. 

↑ Back to the top


Keywords: kbmbsmigrate, kbmbspartner, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2721084
Revision : 2
Created on : 2/3/2017
Published on : 2/3/2017
Exists online : False
Views : 372