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Computer stops responding when you try to open an Offline Files folder in Windows Vista or in Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use client-side caching (CSC) on a computer that is running Windows Vista or Windows Server 2008.
  • You run an application that frequently uses memory mapped network files. For example, you run Microsoft Forefront or Windows Live OneCare.
  • You try to open an Offline Files folder (also known as a CSC folder).
In this scenario, the computer may stop responding.

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Cause

This issue is caused by a file lock leak that occurs after CSC synchronizes the network files. Additionally, the leak causes a mismatch when the NtCreateSection routine tries to match the file locks for a file.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 SP2.

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Vista and for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Mup.sys6.0.6002.2286946,97604-Jun-201210:55x86
For all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Mup.sys6.0.6002.2286958,75204-Jun-201210:52x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Mup.sys6.0.6002.22869128,89604-Jun-201210:48IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about offline files and folder redirection, go to the following Microsoft website: For more information about memory mapped files, go to the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_930642e8985974045b5af6ca604796e9_31bf3856ad364e35_6.0.6002.22869_none_f70f275773e988dc.manifest
File versionNot applicable
File size691
Date (UTC)04-Jun-2012
Time (UTC)11:01
PlatformNot applicable
File nameX86_microsoft-windows-mup_31bf3856ad364e35_6.0.6002.22869_none_af2a8def6ef02ce1.manifest
File versionNot applicable
File size14,927
Date (UTC)04-Jun-2012
Time (UTC)11:01
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_ae22dac08f79279075d2ef69d2a6acd9_31bf3856ad364e35_6.0.6002.22869_none_50dc0521b1baeac8.manifest
File versionNot applicable
File size695
Date (UTC)04-Jun-2012
Time (UTC)11:01
PlatformNot applicable
File nameAmd64_microsoft-windows-mup_31bf3856ad364e35_6.0.6002.22869_none_0b492973274d9e17.manifest
File versionNot applicable
File size15,181
Date (UTC)04-Jun-2012
Time (UTC)11:01
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_13fce4933e08583c45cbae5b4db6cc50_31bf3856ad364e35_6.0.6002.22869_none_4f9e6206724ef0d3.manifest
File versionNot applicable
File size693
Date (UTC)04-Jun-2012
Time (UTC)11:01
PlatformNot applicable
File nameIa64_microsoft-windows-mup_31bf3856ad364e35_6.0.6002.22869_none_af2c31e56eee35dd.manifest
File versionNot applicable
File size15,177
Date (UTC)04-Jun-2012
Time (UTC)11:01
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2719892
Revision : 1
Created on : 1/7/2017
Published on : 9/7/2012
Exists online : False
Views : 236