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Windows NT services monitored by AVIcode may fail to start automatically


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Symptoms

Some Windows NT services may fail to start automatically on computer startup if they are monitored by AVICode. However, the services can be started manually afterwards. If you check the Intercept event log, you see an error similar to this:

[DATA],[TIME],Intercept Stub,Error,None,4000,N/A,A01-CRM-TRNS22,"An error has occurred. Please contact Technical Support if this issue persists.
Error: Monitor initialization timeout expired.
Please contact your system administrator.
Code: [CODE] Type: Internal External Time [DATE] [TIME] Thread: [TID] Raised in: (ret == WAIT_OBJECT_0). CInitThread::InitAndWaitFinish, Caught in: CProfilerCallback::Initialize. 

System information:

Agent version: [INTERCEPT_AGENT_VERSION]
Windows version: [OS_VERSION]
Process ID: [PID]; Instance ID: [IID];
InstanceName: [NAME_OF_THE_SERVICE].

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Cause

Startup time for services can increase due to the way the .NET CLR Profiling API works.

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Resolution

Configure a startup dependency for each of the services that are not starting automatically, to be dependent on the Intercept service (AVICode agent) using this article: 

193888 - How to delay loading of specific services (http://support.microsoft.com/kb/193888)

Also make sure that the Intercept service is set to "Automatic" startup and NOT "Automatic (Delayed start)".

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More Information

This article applies to Windows NT services that are monitored with AVICode 5.6 or 5.7

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Keywords: kb

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Article Info
Article ID : 2695741
Revision : 1
Created on : 1/7/2017
Published on : 4/19/2012
Exists online : False
Views : 367