Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Event 1000, 1001, or 1002 occurs when SCOM is monitoring Exchange Server 2007 or Exchange Server 2010


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Microsoft Exchange Server 2007 or Microsoft Exchange Server 2010.
  • You install Microsoft System Center Operations Manager (SCOM) 2007.
  • You configure SCOM to monitor the Exchange Server installation.
In this scenario, you may receive an error message that resembles the following in the SCOM console:
Monitor - A Receive connector has failed connectivity testing twice within the last 10 minutes.

The details of the error resemble the following:
Property Value

SMTP connectivity test failed for server_name

The following endpoints aren�t functioning:

server_name\SMTP Connector from Internet (domain_name)\0.0.0.0:25\10.8.130. 14:25 4214.3.2 Service not available server_name\SMTP

Connector from Exchange Org\0.0.0,0:25 \10.S.130.14:25 421 4.3.2 Service not available All endpoints were tested. No endpoints were functioning correctly.

Diagnostic command: �Test SmtpConnectivity -MonitoringContext: $true�

1001

Event SourceName: MSsxchange Monitoring SmtpConnectivity
When running the following command in the Exchange Powershell got the following output:

[PS] C:\Windows\system32>Test-SmtpConnectivity -MonitoringContext $true

ReceiveConnector Binding EndPoint StatusCode
---------------- ------- -------- ----------
SMTP Connector from Intern... 0.0.0.0:25 10.8.130.14:25 Error
SMTP Connector from Exchan... 0.0.0.0:25 10.8.130.14:25 Error

Events : {Source: MSExchange Monitoring SmtpConnectivity
Id: 1001
Type: Error
Message: SMTP connectivity test failed for <servername>
The following endpoints aren't functioning:

server_name\SMTP Connector from Internet (domain_name)\0.0.0.0:25\10.8.130.14:25
421 4.3.2 Service not available
server_name\SMTP Connector from Exchange Org\0.0.0.0:25\10.8.130.14:25
421 4.3.2 Service not available
All endpoints were tested.
No endpoints were functioning correctly.}

PerformanceCounters : {}

↑ Back to the top


Cause

This error occurs if the IP address of the Microsoft Exchange server is not bound to a receive connector.

Note You receive this error when SCOM 2007 runs the Test-SMTPConnectivity cmdlet.

↑ Back to the top


Resolution

To resolve this issue, use one of the following methods, as appropriate for your situation.

Method 1

Create a new receive connector.

Method 2

Add the IP address of the Hub Transport server in the Exchange Management Console (EMC). To do this, follow these steps:
  1. Start the EMC.
  2. Expand the server that you want, expand Server Configuration, and then click Hub Transport.
  3. Under the name of the server, right-click the receive connector, and then click Properties.
  4. On the Network tab under Receive mail from remote servers that have these IP addresses, click Add.
  5. In the Address or address range box, type the address of the Hub Transport server.
  6. Click OK two times.
Method 3

Override the monitor in SCOM.

↑ Back to the top


References

For information about how to create a receive connector in Exchange Server 2010, visit the following TechNet website: For information about how to create a receive connector in Exchange Server 2007, visit the following TechNet website: For information about how to override a monitor in SCOM, visit the following TechNet website:

↑ Back to the top


Keywords: KB2681932, kbprb, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2681932
Revision : 1
Created on : 3/2/2012
Published on : 3/2/2012
Exists online : False
Views : 908