Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Office 2000 programs quit immediately after starting after you apply the Office 2000 SR-1/SR-1a update


View products that this article applies to.

This article was previously published under Q267968
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/ ) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When you start one of the Microsoft Office programs, the program quits immediately after it starts.

↑ Back to the top


Cause

You may experience this behavior if all of the following are true:
  • You created an administrative installation of Office by using a CD key that begins with GC6J3.
  • On a network client, you installed Office from this administrative installation.
  • You updated the administrative installation with the SR-1/SR-1a administrative update.
  • You updated the network client from the SR-1/SR-1a administrative installation.

↑ Back to the top


Resolution

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


To resolve this problem, follow these steps:


  1. Using your original Office 2000 CD, create a new administrative installation in a folder that is different from your original administrative installation.

    NOTE: If the product CD Key begins with GC6J3, the Product Key is not valid in Microsoft Office 2000 SR-1/SR-1a. Contact the reseller of your Office product to obtain a valid product CD key, or purchase a valid Microsoft Office 2000 product. After you obtain a valid product CD key, continue with the following steps.

    For more information about purchasing Microsoft Office, browse to the following Microsoft Web site:
  2. Update this new administrative installation with the SR-1/SR-1a administrative update.

    For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
    257983� OFF2000: How to Obtain and Apply the SR-1/SR-1a Update to Administrative Installations
    If you followed steps 1 through 2 because you do not have an SR-1/SR-1a CD, go to step 4.

  3. Using your SR-1/SR-1a CD, create a new administrative installation in a folder that is different from your original administrative installation.

    NOTE: Use the CD key on the back of the SR-1/SR-1a CD case, unless is begins with GC6J3. If the product CD Key begins with GC6J3, the Product Key is not valid in Microsoft Office 2000 SR-1/SR-1a. Contact the reseller of your Office product to obtain a valid product CD key, or purchase a valid Microsoft Office 2000 product. After you obtain a valid product CD key, continue with the follow steps.

    For more information about purchasing Microsoft Office, browse to the following Microsoft Web site:
  4. On a network client that is experiencing the symptoms described earlier in this article, click Start on the Windows taskbar, and then click Run.
  5. In the Open box, type a command line similar to the following:
    path to new admin install\Setup.exe /fv Data1.msi
    where path to new admin install is the full path to the new administrative installation.

    This recaches the Data1.msi file from the new administrative installation onto the network client.
  6. Click Start, and then click Run.
  7. In the Open box, type regedit, and then click OK.
  8. In Registry Editor, find the following subkey (folder):
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
    Click the plus sign (+) next to this folder. If you see only one subkey in this folder that has a 32-character {GUID} (globally unique identifier), select that subkey and go to step 9.

    If you see more than one subkey that has a 32-character {GUID}, select each one until you find the one whose DisplayName value (in the right pane) matches your version of Office.

    For example, if you have Office 2000 Premium CD 1 and CD 2 installed, the 32-character {GUID} and the DisplayName value are:

    Office 2000 Premium CD 1

    {GUID}:         {00000409-78E1-11D2-B60F-006097C998E7}
    DisplayName:    Microsoft Office 2000 Premium

    Office 2000 Premium CD 2

    {GUID}:         {00040409-78E1-11D2-B60F-006097C998E7}
    DisplayName:    Microsoft Office 2000 Disc 2
  9. For the selected {GUID} subkey, select the ProductID string value in the right pane.
  10. On the Edit menu, click Rename.
  11. Type OldProductID and then press ENTER.
  12. On the Registry menu, click Exit.
  13. Start any Office program.
  14. When the Microsoft Office 2000 User Information dialog box appears, type the CD Key that you used to create the new administrative installation.

↑ Back to the top


More information

230848� OFF2000: Numbering Scheme for Product Code GUIDs

↑ Back to the top


Keywords: kbtshoot, kbstartprogram, kbprb, KB267968

↑ Back to the top

Article Info
Article ID : 267968
Revision : 6
Created on : 5/7/2007
Published on : 5/7/2007
Exists online : False
Views : 357